freebsd-ports/devel/cocktail/files/patch-specs-modula-minilax-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

156 lines
5.8 KiB
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./specs/modula/minilax/Makefile Tue Feb 15 14:29:06 1994
+++ ./specs/modula/minilax/Makefile Wed Aug 25 11:42:24 2004
@@ -15,97 +15,99 @@
lpp -xzj minilax.pars;
minilax.rex: minilax.scan Scanner.rpp
- rpp < minilax.scan > minilax.rex;
+ $(RPP) < minilax.scan > minilax.rex;
Scanner.md Scanner.mi: minilax.rex
- rex -d minilax.rex;
+ $(REX) -d minilax.rex;
Parser.md Parser.mi: Parser.lalr
- lalr -d Parser.lalr;
+ $(LALR) -d Parser.lalr;
Tree.md Tree.mi: minilax.cg
- cg -dimRDI0 minilax.cg;
+ $(CG) -dimRDI0 minilax.cg;
Semantics.md Semantics.mi: minilax.cg
- cg -DI0 minilax.cg;
+ $(CG) -DI0 minilax.cg;
Definitions.md Definitions.mi Definitions.TS: Definitions.cg
- cg -dim4 Definitions.cg;
+ $(CG) -dim4 Definitions.cg;
Tree.TS: minilax.cg
- echo SELECT AbstractSyntax Output | cat - minilax.cg | cg -4
+ echo SELECT AbstractSyntax Output | cat - minilax.cg | $(CG) -4
Types.md Types.mi: Types.puma Tree.TS
- puma -dipk Types.puma;
+ $(PUMA) -dipk Types.puma;
ICode.md ICode.mi: ICode.puma Tree.TS Definitions.TS
- puma -di ICode.puma;
+ $(PUMA) -di ICode.puma;
test: $(SOURCES)
- cg -dimRDI09 minilax.cg;
+ $(CG) -dimRDI09 minilax.cg;
make minilax
time minilax < in5
wc Semantics.mi
size Semantics.o
- cg -dimRDI9 minilax.cg;
+ $(CG) -dimRDI9 minilax.cg;
make minilax
time minilax < in5
wc Semantics.mi
size Semantics.o
- cg -dimRDIL9 minilax.cg;
+ $(CG) -dimRDIL9 minilax.cg;
make minilax
time minilax < in5
wc Semantics.mi
size Semantics.o
- cg -dimRDIK9 minilax.cg;
+ $(CG) -dimRDIK9 minilax.cg;
make minilax
time minilax < in5
wc Semantics.mi
size Semantics.o
test2: $(SOURCES)
- cg -dimRD minilax.cg
- cg -I minilax.cg; make minilax; minilax < in1
- cg -I0 minilax.cg; make minilax; minilax < in1
- cg -IL minilax.cg; make minilax
- cg -IK minilax.cg; make minilax; minilax < in1
- cg -dimRD0 minilax.cg
- cg -I minilax.cg; make minilax
- cg -I0 minilax.cg; make minilax; minilax < in1
- cg -IL minilax.cg; make minilax
- cg -IK minilax.cg; make minilax
- cg -dimRDL minilax.cg
- cg -I minilax.cg; make minilax; minilax < in1
- cg -I0 minilax.cg; make minilax; minilax < in1
- cg -IL minilax.cg; make minilax; minilax < in1
- cg -IK minilax.cg; make minilax; minilax < in1
+ $(CG) -dimRD minilax.cg
+ $(CG) -I minilax.cg; make minilax; minilax < in1
+ $(CG) -I0 minilax.cg; make minilax; minilax < in1
+ $(CG) -IL minilax.cg; make minilax
+ $(CG) -IK minilax.cg; make minilax; minilax < in1
+ $(CG) -dimRD0 minilax.cg
+ $(CG) -I minilax.cg; make minilax
+ $(CG) -I0 minilax.cg; make minilax; minilax < in1
+ $(CG) -IL minilax.cg; make minilax
+ $(CG) -IK minilax.cg; make minilax
+ $(CG) -dimRDL minilax.cg
+ $(CG) -I minilax.cg; make minilax; minilax < in1
+ $(CG) -I0 minilax.cg; make minilax; minilax < in1
+ $(CG) -IL minilax.cg; make minilax; minilax < in1
+ $(CG) -IK minilax.cg; make minilax; minilax < in1
trace: $(SOURCES)
- cg -dimRwDI09 minilax.cg; make minilax; minilax < in1
- cg -I09T minilax.cg; make minilax; minilax < in1
- cg -I09YZ minilax.cg; make minilax; minilax < in1
- cg -I09X minilax.cg; make minilax; minilax < in1
- cg -I09Y minilax.cg; make minilax; minilax < in1
- cg -I09Z minilax.cg; make minilax; minilax < in1
- cg -dimRwDI9 minilax.cg; make minilax; minilax < in1
- cg -I9T minilax.cg; make minilax; minilax < in1
- cg -I9YZ minilax.cg; make minilax; minilax < in1
- cg -I9X minilax.cg; make minilax; minilax < in1
- cg -I9Y minilax.cg; make minilax; minilax < in1
- cg -I9Z minilax.cg; make minilax; minilax < in1
- cg -dimRwDIL9 minilax.cg; make minilax; minilax < in1
- cg -IL9T minilax.cg; make minilax; minilax < in1
- cg -IL9YZ minilax.cg; make minilax; minilax < in1
- cg -IL9X minilax.cg; make minilax; minilax < in1
- cg -IL9Y minilax.cg; make minilax; minilax < in1
- cg -IL9Z minilax.cg; make minilax; minilax < in1
- cg -dimRwDIK9 minilax.cg; make minilax; minilax < in1
- cg -IK9T minilax.cg; make minilax; minilax < in1
- cg -IK9YZ minilax.cg; make minilax; minilax < in1
- cg -IK9X minilax.cg; make minilax; minilax < in1
- cg -IK9Y minilax.cg; make minilax; minilax < in1
- cg -IK9Z minilax.cg; make minilax; minilax < in1
+ $(CG) -dimRwDI09 minilax.cg; make minilax; minilax < in1
+ $(CG) -I09T minilax.cg; make minilax; minilax < in1
+ $(CG) -I09YZ minilax.cg; make minilax; minilax < in1
+ $(CG) -I09X minilax.cg; make minilax; minilax < in1
+ $(CG) -I09Y minilax.cg; make minilax; minilax < in1
+ $(CG) -I09Z minilax.cg; make minilax; minilax < in1
+ $(CG) -dimRwDI9 minilax.cg; make minilax; minilax < in1
+ $(CG) -I9T minilax.cg; make minilax; minilax < in1
+ $(CG) -I9YZ minilax.cg; make minilax; minilax < in1
+ $(CG) -I9X minilax.cg; make minilax; minilax < in1
+ $(CG) -I9Y minilax.cg; make minilax; minilax < in1
+ $(CG) -I9Z minilax.cg; make minilax; minilax < in1
+ $(CG) -dimRwDIL9 minilax.cg; make minilax; minilax < in1
+ $(CG) -IL9T minilax.cg; make minilax; minilax < in1
+ $(CG) -IL9YZ minilax.cg; make minilax; minilax < in1
+ $(CG) -IL9X minilax.cg; make minilax; minilax < in1
+ $(CG) -IL9Y minilax.cg; make minilax; minilax < in1
+ $(CG) -IL9Z minilax.cg; make minilax; minilax < in1
+ $(CG) -dimRwDIK9 minilax.cg; make minilax; minilax < in1
+ $(CG) -IK9T minilax.cg; make minilax; minilax < in1
+ $(CG) -IK9YZ minilax.cg; make minilax; minilax < in1
+ $(CG) -IK9X minilax.cg; make minilax; minilax < in1
+ $(CG) -IK9Y minilax.cg; make minilax; minilax < in1
+ $(CG) -IK9Z minilax.cg; make minilax; minilax < in1
clean:
- rm -f Scanner.m? Parser.m? Tree.m? Semantics.m? Definitions.m? Types.m? ICode.m?
- rm -f core *.TS *.bak *.[dimor] _Debug minilax minilax.rex Parser.lalr Scanner.rpp
+ -rm -f Scanner.m? Parser.m? Tree.m? Semantics.m? Definitions.m? Types.m? ICode.m?
+ -rm -f $(STDCLEAN)
+ -rm -f *.TS *.bak *.[dimor] _Debug minilax minilax.rex Parser.lalr Scanner.rpp
+.include "../../Makefile.inc"