d9029c5139
Major changes: - new installation layout, resembling RPM packages: - client = Client Utilities + Development Libraries + Shared components - server = MySQL Server + Embedded - new build system: cmake instead of autotools - fewer port knobs Expect various breakages, but if we are lucky this could become the new default mysql port.
18 lines
654 B
Text
18 lines
654 B
Text
--- sql/CMakeLists.txt.orig 2010-12-23 17:31:28.000000000 +0100
|
|
+++ sql/CMakeLists.txt 2010-12-23 17:33:36.000000000 +0100
|
|
@@ -245,6 +245,7 @@
|
|
|
|
IF(INSTALL_LAYOUT STREQUAL "STANDALONE")
|
|
|
|
+IF(FALSE)
|
|
# We need to create empty directories (data/test) the installation.
|
|
# This does not work with current CPack due to http://www.cmake.org/Bug/view.php?id=8767
|
|
# Avoid completely empty directories and install dummy file instead.
|
|
@@ -286,6 +287,7 @@
|
|
INSTALL(FILES ${DUMMY_FILE} DESTINATION data/mysql COMPONENT DataFiles)
|
|
ENDIF()
|
|
ENDIF()
|
|
+ENDIF()
|
|
|
|
ADD_CUSTOM_TARGET(show-dist-name
|
|
COMMAND ${CMAKE_COMMAND} -E echo "${CPACK_PACKAGE_FILE_NAME}"
|