freebsd-ports/textproc/zorba/files/patch-test-rbkt_CMakeLists.txt
Pietro Cerutti 4b7c37750e - Update to 2.0.2
Changelog since 1.4.0

	version 2.0.2

	* Fixed bug #3401971 (node-by-reference on dynamic collections)
	* documentation improvements
	* installer improvements
	* Fixed bug #3403291 (build for Fedora 15)
	* Don't install the .so for test modules
	* Fix for running ctest on Windows

	version 2.0.1

	* Custom Full-text stemming.
	* Custom Full-text tokenization.
	* Fixed scripting bug where apply statement was considered a
	* sequential expr even if the source expr was non-updating and
	* non-sequential.
	* Fixed bug #3394400 (Element replacement, really unexpected result)
	* Fixed bug #3394588 (Unexpected error during pul undo)
	* Fixed bugs #3398511 and #3398552 with "make install"
	* Fixed bug #3398521 for compiling with ZORBA_NO_XMLSCHEMA

	version 2.0

	* Zorba 2.0 is a major rewrite of previous versions. It doesn't claim
	  to preserve backwards compatibility with any 1.X version.
	  Host language API changes have been made to the following components:
		- External functions API
		- XmlDataManager
		- Error reporting
		- Debugger API
	  XQuery language and API changes have been made to the following components:
		- XQuery Scripting Extension
		- Function APIs
		- XQuery Data Definition Facility
		- XQuery modules and module versioning
		- Changes to conform with the latest XQuery 3.0
		- Namespaces of annotations, errors, collations.
	* In addition to host language API and XQuery language improvements, plenty of
	  bug fixes and optimizations have been made.

Feature safe:	yes
2011-11-30 15:34:15 +00:00

11 lines
556 B
Text

--- test/rbkt/CMakeLists.txt.orig 2011-09-10 17:56:08.000000000 +0200
+++ test/rbkt/CMakeLists.txt 2011-09-15 10:05:12.000000000 +0200
@@ -71,7 +71,7 @@
MESSAGE(STATUS "Did NOT find Boost SYSTEM component - not building multithreaded test driver")
SET (ZORBATEST_TESTDRIVER_MT_AVAILABLE FALSE)
ELSE (NOT Boost_SYSTEM_FOUND)
- SET (Boost_system_lib "boost_system-mt")
+ SET (Boost_system_lib ${Boost_LIBRARIES})
ENDIF (NOT Boost_SYSTEM_FOUND)
ENDIF (Boost_MAJOR_VERSION EQUAL 1 AND Boost_MINOR_VERSION GREATER 34)