- Remove leading, undefined article from COMMENT - Add graphics/ImageMagick to RUN_DEPENDS - Enable garbage collection via devel/boehm-gc-threaded [1] - Sort variables - Use autotools [1] - Use texlive, and don't install files already installed by it [1] - Use options helpers - Add option OFFSCREEN (default off) to enable offscreen rendering using OSMesa library - Add support for stage dir [1] - Strip binary file asy - Add files/patch-configure.ac and files/patch-settings.cc - Remove Author field, and use a single space after WWW in pkg-descr [1] Release Notes: http://sourceforge.net/projects/asymptote/files/2.32/ PR: ports/190196 [1] Submitted by: Shin-ya Murakami <murashin@gfd-dennou.org>
33 lines
1.4 KiB
Text
33 lines
1.4 KiB
Text
--- ./Makefile.in.orig 2014-05-22 18:11:41.000000000 +0200
|
|
+++ ./Makefile.in 2014-05-27 05:26:25.000000000 +0200
|
|
@@ -53,7 +53,6 @@
|
|
EXEXTRA = piicon.eps *.views *.dat *.bib
|
|
DOCEXTRA = *.asy *.csv *.dat latexusage.tex externalprc.tex pixel.pdf
|
|
KEYWORDS = base $(ASYMPTOTE_SITEDIR)
|
|
-LATEXFILES = asymptote.sty asycolors.sty ocg.sty latexmkrc
|
|
CONTEXTFILES = colo-asy.tex
|
|
ASY = ./asy -dir base -config "" -render=0
|
|
|
|
@@ -84,7 +83,7 @@
|
|
asydir = $(datadir)/asymptote
|
|
GUIdir = $(asydir)/GUI
|
|
docdir = $(DESTDIR)@docdir@
|
|
-exampledir = $(docdir)/examples
|
|
+exampledir = $(datadir)/examples/asymptote
|
|
animationsdir = $(exampledir)/animations
|
|
latexdir = $(DESTDIR)@latexdir@
|
|
contextdir = $(DESTDIR)@contextdir@
|
|
@@ -234,13 +233,11 @@
|
|
${INSTALL} -p -m 644 base/*.asy $(addprefix base/,$(EXTRA)) \
|
|
asy-keywords.el $(asydir)
|
|
${INSTALL} -p -m 755 GUI/*.py $(GUIdir)
|
|
- ln -sf @datadir@/asymptote/GUI/xasy.py $(bindir)/$(XNAME)
|
|
${INSTALL} -p -m 644 examples/*.asy $(addprefix examples/,$(EXEXTRA)) \
|
|
doc/extra/*.asy $(addprefix doc/,$(DOCEXTRA)) $(exampledir)
|
|
${INSTALL} -p -m 644 examples/animations/*.asy \
|
|
examples/animations/inlinemovie.tex \
|
|
examples/animations/inlinemovie3.tex $(animationsdir)
|
|
- -${INSTALL} -p -m 644 $(addprefix doc/,$(LATEXFILES)) $(latexdir)
|
|
-${INSTALL} -p -m 644 $(addprefix doc/,$(CONTEXTFILES)) $(contextdir)
|
|
|
|
install-html: html
|