freebsd-ports/net/x2goclient/files/patch-sshprocess.h
Pawel Pekala 2ffc000fb1 - Update to version 3.99.2.2
- Use pkg-plist to register installed files
- Add option to disable LDAP support
- Don't install copy of GPLv2 license

PR:		ports/172044
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
Feature safe:	yes
2012-11-01 09:28:54 +00:00

15 lines
350 B
C

--- sshprocess.h.orig 2011-11-25 21:08:10.000000000 +0900
+++ sshprocess.h 2011-12-20 01:56:29.000000000 +0900
@@ -17,6 +17,12 @@
#ifndef SSHPROCESS_H
#define SSHPROCESS_H
+#ifndef Q_OS_WIN
+#include <sys/types.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
+#include <arpa/inet.h>
+#endif
#include <libssh/libssh.h>
#include <QObject>