13966ac24e
offers the following basic CW services to a caller program: o Morse code character translation tables, and lookup functions o Morse code low-level timing calculations o A 'sidetone' generation and queueing system, using either the system sound card, the console speaker, or both o Optional keying control for an external device, say a transmitter, or an oscillator o CW character and string send routines, tied in with the character lookup o CW receive routines, also tied in to the character lookup o Adaptive speed tracking of received CW o An iambic keyer, with both Curtis 8044 types A and B timing o Straight key emulation Submitted by: self
19 lines
464 B
Text
19 lines
464 B
Text
--- src/cw/Makefile.orig 2007-12-25 22:55:33.000000000 -0500
|
|
+++ src/cw/Makefile 2007-12-25 22:56:25.000000000 -0500
|
|
@@ -19,14 +19,14 @@
|
|
|
|
include ../../Makefile.inc
|
|
CC = $(AC_CC)
|
|
-CFLAGS = $(AC_CFLAGS) $(AC_DEFS) -I../cwlib -I../cwutils
|
|
+CFLAGS = $(AC_CFLAGS) $(AC_DEFS) -I../cwlib -I../cwutils -I$(includedir)
|
|
GZIP = $(AC_GZIP)
|
|
|
|
SHELL = /bin/sh
|
|
|
|
default: all
|
|
|
|
-LIBS = -L../cwlib -lcw
|
|
+LIBS = -L../cwlib -lcw $(AC_LIBS)
|
|
|
|
# Build the cw binary.
|
|
all: cw
|