This update resolves a package installation conflict with textproc/py-texttable as both ports installs "texttable.py" into the same place. [1] Also while I'm here: * Switch to GitHub for a while as no sdist tarballs are available at PyPi. * Make the port concurrent safe because it installs scripts outside of the site-lib directory. * Remove the "testdata" directory to prevent possible package conflicts as it's only required for the test suite. * Add a "do-test" target to make future QA easier. Changelog: https://github.com/google/textfsm/releases/tag/v1.1.0 https://github.com/google/textfsm/releases/tag/v1.1.1 PR: 244257 Reported by: John Hein <jcfyecrayz@liamekaens.com> [1] MFH: 2020Q1
13 lines
412 B
Python
13 lines
412 B
Python
Remove "testdata" directory from installation. It is only required for the
|
|
testsuite.
|
|
|
|
--- setup.py.orig 2019-11-26 11:17:07 UTC
|
|
+++ setup.py
|
|
@@ -52,7 +52,6 @@ setup(name='textfsm',
|
|
]
|
|
},
|
|
include_package_data=True,
|
|
- package_data={'textfsm': ['../testdata/*']},
|
|
install_requires=['six', 'future'],
|
|
setup_requires=['pytest-runner'],
|
|
tests_require=['pytest'])
|