freebsd-ports/security/fressh/files/patch-crypto::ssh_crypto_openssl.c
Alexey Dokuchaev 0ddbd90408 - Fix the build with modern GCC [1]
- Kill teeny pkg-plist per portlint(1)
2007-06-18 20:37:33 +00:00

25 lines
461 B
C

$FreeBSD$
--- crypto/ssh_crypto_openssl.c.orig
+++ crypto/ssh_crypto_openssl.c
@@ -44,8 +44,10 @@
#include <stdlib.h>
#include <errno.h>
#include <string.h>
+#include <sys/types.h>
#include <openssl/rand.h>
+#include <openssl/sha.h>
#include <openssl/opensslv.h>
@@ -183,7 +183,7 @@
new_bn = BN_bin2bn(data, bytes, &((*num)->num));
if (new_bn == NULL)
return (-1);
- (BIGNUM *) * num = new_bn;
+ *num = (BIGNUM *) new_bn;
return (0);
}