freebsd-ports/misc/countrycodes/files/patch-src_Makefile
Jean-Yves Lefort 24d34901c9 Add countrycodes.
Countrycodes is an ISO 3166 country code finder. It is mainly used to know
the country a domain name belongs to. It also allows searching by 2 or 3
letters codes, country number and country name.

WWW: http://www.grigna.com/diego/linux/countrycodes/

PR:		ports/83830
Submitted by:	Emanuel Haupt <ehaupt@critical.ch>
2005-07-24 19:42:03 +00:00

32 lines
782 B
Text

--- src/Makefile.orig Sat Feb 1 16:56:08 2003
+++ src/Makefile Sun Jul 24 21:39:05 2005
@@ -58,11 +58,14 @@
PROGRAM = iso3166
-all: $(PROGRAM)
+all: $(PROGRAM) iso3166.1
$(PROGRAM): $(ISO3166OBJ)
$(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
+iso3166.1: ${docdir}/iso3166.1.in
+ @$(SEDBIN) $(SEDCMDS) $> > $@
+
clean:
rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
@@ -70,11 +73,8 @@
strip $(PROGRAM)
install:
- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
- @echo "Installing man page..."
- @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
- @chown 0.0 ${mandir}/iso3166.1
- @echo
+ $(BSD_INSTALL_PROGRAM) ${srcdir}/$(PROGRAM) ${bindir}
+ $(BSD_INSTALL_MAN) iso3166.1 ${mandir}
uninstall:
rm -f ${bindir}/$(PROGRAM)