freebsd-ports/x11/mate-screensaver/files/patch-data_Makefile.am
Koop Mast a236e2d0bf Say hello to Mate 1.6.
Mate is a lite desktop forked from gnome2.

Most of the work is done by Jeremy Messenger (mezz@). The only thing I did
was update a few ports to later 1.6 release and attempting to keep up with
ports infra changes. Resulting bugs are all mine.

Mate is a sort of replacement for Gnome 2. So people wanting to keep a
Gnome 2 like desktop should switch. Gnome 2 will be replaced by Gnome 3
in the near future. This switch will be announce with a transition time
so people have more time to switch if they haven't already.

This release was made possible by everyone that send friendly pokes to
keep mate on my mind.

Approved by:	portmgr (bapt)
2013-11-23 11:39:07 +00:00

70 lines
3.5 KiB
Text

--- data/Makefile.am.orig 2012-07-27 22:26:17.000000000 -0500
+++ data/Makefile.am 2012-07-27 22:26:55.000000000 -0500
@@ -82,35 +82,35 @@
endif
install-data-hook:
- @system=`uname`; \
- if test -f /usr/include/security/pam_appl.h; then \
- if test '!' -d $(DESTDIR)$(PAM_PREFIX)/pam.d; then \
- $(mkinstalldirs) $(DESTDIR)$(PAM_PREFIX)/pam.d; \
- chmod 755 $(DESTDIR)$(PAM_PREFIX)/pam.d; \
- fi; \
- if test $$system = Linux; then \
- if test '!' -f $(DESTDIR)$(PAM_PREFIX)/pam.d/mate-screensaver; then \
- $(INSTALL_DATA) mate-screensaver $(DESTDIR)$(PAM_PREFIX)/pam.d/mate-screensaver; \
- fi; \
- if test "x$(PAM_PREFIX)" != "x/etc/pam.d"; then \
- echo "***" ; \
- echo "*** Warning: mate-screensaver has been compiled with support for" ; \
- echo "*** Pluggable Authentication Modules (PAM). However, you may need to" ; \
- echo "*** manually install $(PAM_PREFIX)/pam.d/mate-screensaver" ; \
- echo "*** to /etc/pam.d/mate-screensaver. Otherwise, unlocking might" ; \
- echo "*** not work." ; \
- echo "***" ; \
- echo "*** Note: If you are using SuSE/Novell you may have to modify this file." ; \
- echo "***" ; \
- fi; \
- fi; \
- if test $$system = SunOS; then \
- echo "***" ; \
- echo "*** Warning: mate-screensaver has been compiled with support for" ; \
- echo "*** Pluggable Authentication Modules (PAM). However, you" ; \
- echo "*** need to manually add authentication for mate-screensaver in" ; \
- echo "*** $(PAM_PREFIX)/pam.conf or /etc/pam.conf." ; \
- echo "*** Otherwise, unlocking might not work." ; \
- echo "***" ; \
- fi; \
- fi
+# @system=`uname`; \
+# if test -f /usr/include/security/pam_appl.h; then \
+# if test '!' -d $(DESTDIR)$(PAM_PREFIX)/pam.d; then \
+# $(mkinstalldirs) $(DESTDIR)$(PAM_PREFIX)/pam.d; \
+# chmod 755 $(DESTDIR)$(PAM_PREFIX)/pam.d; \
+# fi; \
+# if test $$system = Linux; then \
+# if test '!' -f $(DESTDIR)$(PAM_PREFIX)/pam.d/mate-screensaver; then \
+# $(INSTALL_DATA) mate-screensaver $(DESTDIR)$(PAM_PREFIX)/pam.d/mate-screensaver; \
+# fi; \
+# if test "x$(PAM_PREFIX)" != "x/etc/pam.d"; then \
+# echo "***" ; \
+# echo "*** Warning: mate-screensaver has been compiled with support for" ; \
+# echo "*** Pluggable Authentication Modules (PAM). However, you may need to" ; \
+# echo "*** manually install $(PAM_PREFIX)/pam.d/mate-screensaver" ; \
+# echo "*** to /etc/pam.d/mate-screensaver. Otherwise, unlocking might" ; \
+# echo "*** not work." ; \
+# echo "***" ; \
+# echo "*** Note: If you are using SuSE/Novell you may have to modify this file." ; \
+# echo "***" ; \
+# fi; \
+# fi; \
+# if test $$system = SunOS; then \
+# echo "***" ; \
+# echo "*** Warning: mate-screensaver has been compiled with support for" ; \
+# echo "*** Pluggable Authentication Modules (PAM). However, you" ; \
+# echo "*** need to manually add authentication for mate-screensaver in" ; \
+# echo "*** $(PAM_PREFIX)/pam.conf or /etc/pam.conf." ; \
+# echo "*** Otherwise, unlocking might not work." ; \
+# echo "***" ; \
+# fi; \
+# fi