freebsd-ports/www/interchange/files/patch-Makefile.PL
Raphael Kubo da Costa 74c8350522 - Reset maintainership to ports@.
- Support staging.
- Modernise the Makefile:
  * Switch from USE_BZIP2=yes to USES=tar:bzip2
  * Use <OPTION>_RUN_DEPENDS instead of including bsd.port.options.mk and
    doing checks ourselves.
  * Drop the pkg-deinstall and pkg-install scripts. Instead, just rely on
    the ports infrastructure with GROUPS/USERS to create the "interch"
    group/user and use the plist to create /var/run/interchange and change
    the ownership in %D/interchange.
- Add some missing entries to the plist.

Based on a patch sent by the former maintainer.

PR:		191464
Submitted by:	loader@freebsdmall.com (based on)
2014-07-06 20:10:12 +00:00

22 lines
780 B
Perl

From: René Hertell <interchange@hertell.com>
Date: Wed, 24 Jun 2009 15:28:50 +0000 (+0300)
Subject: Fixed Makefile.PL to honour the DESTDIR-variable when doing eg. "make DESTDIR=/tmp...
X-Git-Tag: REL_5_7_2~51
X-Git-Url: http://git.icdevgroup.org/?p=interchange.git;a=commitdiff_plain;h=837be0427f40fd8f2d34fc3d6bbdc4d84aeb4ad3
Fixed Makefile.PL to honour the DESTDIR-variable when doing eg. "make DESTDIR=/tmp/pacage install"
---
diff --git a/Makefile.PL b/Makefile.PL
index ec81b8c..b26c529 100644
--- Makefile.PL
+++ Makefile.PL
@@ -739,7 +739,7 @@ sub MY::install {
next unless $MV::Default{$_};
push @args, "$_=$MV::Default{$_}";
}
- push @args, 'final=$(INSTALLARCHLIB)';
+ push @args, 'final=$(DESTDIR)$(INSTALLARCHLIB)';
my $argstring = join " ", @args;