freebsd-ports/cad/z88/files/patch-make_make__unix__64_z88x.mk.gcc64
Kurt Jaeger d460c1a711 cad/z88: update 13.0 -> 15
- Changes PORTVERSION to DISTVERSION
- Sets submitter as MAINTAINER.
- Uses USE_GITHUB instead of MASTER_SITES
- Sets LICENSE
- Sets appropriate dependencies, USES, USE_X
- Adds an EXAMPLES option
- Adds a pkg-message to explain how the port must be used, as it
  is not self-evident (The software assumes all files in the same
  directory instead of distributed into bin/, ${DATADIR} etc so I had
  to find a work around: the solution is easy for the user).

PR:		233772
Submitted by:	Lorenzo Salvadore <phascolarctos@protonmail.ch>
Reviewed by:	chitty_cloud@me.com
Relnotes:	https://forum.z88.de/viewtopic.php?f=18&t=885
2018-12-31 13:33:55 +00:00

12 lines
560 B
Text

--- make/make_unix_64/z88x.mk.gcc64.orig 2018-12-05 14:30:53 UTC
+++ make/make_unix_64/z88x.mk.gcc64
@@ -13,8 +13,7 @@ CFLAGS = -I$(DIRCOM) -DFR_UNIX -DFR_XDOU
LDLIBSOX = -lm -lc
-OBJECTSX = z88x.o ale88x.o dyn88x.o clr88.o koi88x.o rea88x.o stop88x.o\
- sub88x.o who88x.o wlog88x.o wria88x.o wrim88x.o z88fx.o z88tx.o lan88x.o
+OBJECTSX = z88x.o ale88x.o dyn88x.o clr88.o koi88x.o rea88x.o stop88x.o sub88x.o who88x.o wlog88x.o wria88x.o wrim88x.o z88fx.o z88tx.o lan88x.o
z88x: $(OBJECTSX)
$(CC) $(CFLAGS) -o $@ $(OBJECTSX) $(LDLIBSOX)