- Refresh distinfo [1] - Fix SSL [2] - Add missing dependencies [1] - Assign maintainer to submitter [1] - Make PNG and JPEG support optional [1] PR: 238356 [1] PR: 233985 [2] Submitted by: Lorenzo Salvadore <phascolarctos@protonmail.ch> [1] Submitted by: Nathan <ndowens@yahoo.com> [2] Reported by: tigersharke@gmail.com [1] Reported by: jhibbits [2]
41 lines
1.1 KiB
Text
41 lines
1.1 KiB
Text
Patches obtained from:
|
|
http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/www/dillo/patches/
|
|
|
|
$NetBSD: patch-configure,v 1.1 2018/03/24 15:40:07 ryoon Exp $
|
|
|
|
* Detect OpenSSL 1.1.0
|
|
|
|
--- configure.orig 2015-06-30 14:07:22.000000000 +0000
|
|
+++ configure
|
|
@@ -6018,11 +6018,11 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_
|
|
#ifdef __cplusplus
|
|
extern "C"
|
|
#endif
|
|
-char SSL_library_init ();
|
|
+void OPENSSL_config ();
|
|
int
|
|
main ()
|
|
{
|
|
-return SSL_library_init ();
|
|
+OPENSSL_config ();
|
|
;
|
|
return 0;
|
|
}
|
|
$NetBSD: patch-dpi_https.c,v 1.1 2018/03/24 15:40:07 ryoon Exp $
|
|
|
|
* Support OpenSSL 1.1.0
|
|
|
|
--- dpi/https.c.orig 2015-06-30 14:06:08.000000000 +0000
|
|
+++ dpi/https.c
|
|
@@ -476,7 +476,11 @@ static int handle_certificate_problem(SS
|
|
case X509_V_ERR_DEPTH_ZERO_SELF_SIGNED_CERT:
|
|
/*Either self signed and untrusted*/
|
|
/*Extract CN from certificate name information*/
|
|
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
|
if ((cn = strstr(remote_cert->name, "/CN=")) == NULL) {
|
|
+#else
|
|
+ if ((cn = strstr(X509_get_subject_name(remote_cert), "/CN=")) == NULL) {
|
|
+#endif
|
|
strcpy(buf, "(no CN given)");
|
|
} else {
|
|
char *cn_end;
|