50 lines
1.5 KiB
Text
50 lines
1.5 KiB
Text
|
|
$FreeBSD$
|
|
|
|
--- configure.orig Wed Dec 12 10:12:41 2001
|
|
+++ configure Tue Dec 25 15:21:43 2001
|
|
@@ -6186,6 +6186,9 @@
|
|
os2*)
|
|
LIBS=
|
|
;;
|
|
+freebsd*)
|
|
+ CPPFLAGS="${CPPFLAGS} ${X_CFLAGS}"
|
|
+ ;;
|
|
esac
|
|
for ac_hdr in sys/byteorder.h compat.h getopt.h
|
|
do
|
|
@@ -7357,8 +7360,6 @@
|
|
if test $? -eq 0; then
|
|
if test -z "`egrep -i '(unrecognize|unknown)' conftest.out | grep pthread`" && test -z "`egrep -i '(error|incorrect)' conftest.out`" ; then
|
|
ac_cv_have_dash_pthread=yes
|
|
- CFLAGS="$CFLAGS -pthread"
|
|
- CXXFLAGS="$CXXFLAGS -pthread"
|
|
fi
|
|
fi
|
|
rm -f conftest*
|
|
@@ -7392,7 +7393,7 @@
|
|
EOF
|
|
|
|
if test "$ac_cv_have_dash_pthread" = "yes"; then
|
|
- _PTHREAD_LDFLAGS=""
|
|
+ _PTHREAD_LDFLAGS="-pthread"
|
|
else
|
|
_PTHREAD_LDFLAGS="-lc_r"
|
|
fi
|
|
@@ -9839,7 +9840,7 @@
|
|
fi
|
|
MOC=$HOST_MOC
|
|
|
|
- QT_CFLAGS="-I${QTDIR}${QTINCDIR} -DQT_GENUINE_STR"
|
|
+ QT_CFLAGS="-I${QTDIR}/include/X11/qt -DQT_GENUINE_STR"
|
|
QT_LIBS="-L/usr/X11R6/lib -L${QTDIR}/lib -lqt -lXext -lX11"
|
|
|
|
# Check whether --with-static-qt or --without-static-qt was given.
|
|
@@ -13711,6 +13712,7 @@
|
|
echo "configure: warning: Recreating autoconf.mk with updated nspr-config output" 1>&2
|
|
if test ! "$VACPP" && test -z "$_WIN32_MSVC"; then
|
|
NSPR_LIBS=`./nsprpub/config/nspr-config --prefix=$MOZ_BUILD_ROOT/dist --exec-prefix=$MOZ_BUILD_ROOT/dist --libs`
|
|
+ NSPR_LIBS="$NSPR_LIBS $BSD_PTHREAD_LIBS"
|
|
$PERL -pi.bak -e "s {^NSPR_LIBS\s*=.*} {NSPR_LIBS = $NSPR_LIBS }" config/autoconf.mk
|
|
fi
|
|
if test -z "$_WIN32_MSVC"; then
|