freebsd-ports/net-im/jabberd/files/patch-etc__templates__Makefile.in
Martin Matuska 2cd36e3234 Remove pkg-install and pkg-deinstall
Use .sample config files instead of .dist
Improve pkg-plist
2014-11-22 11:40:08 +00:00

31 lines
1.1 KiB
Text

--- etc/templates/Makefile.in.orig 2014-02-24 10:13:54.000000000 +0100
+++ etc/templates/Makefile.in 2014-11-22 12:01:11.535347369 +0100
@@ -275,8 +275,8 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
templatesdir = $(sysconfdir)/templates
-templates_DATA = roster.xml.dist
-EXTRA_DIST = roster.xml.dist.in
+templates_DATA = roster.xml.sample
+EXTRA_DIST = roster.xml.sample.in
edit = sed \
-e 's,@sysconfdir\@,$(sysconfdir),g' \
-e 's,@localstatedir\@,$(localstatedir),g' \
@@ -506,14 +506,9 @@
mv $@.tmp $@
install-data-hook:
- @list='$(templates_DATA)'; for p in $$list; do \
- dest=`echo $$p | sed -e s/.dist//`; \
- if test -f $(DESTDIR)$(templatesdir)/$$dest; then \
- echo "$@ will not overwrite existing $(DESTDIR)$(templatesdir)/$$dest"; \
- else \
- echo " $(INSTALL_DATA) $$p $(DESTDIR)$(templatesdir)/$$dest"; \
- $(INSTALL_DATA) $$p $(DESTDIR)$(templatesdir)/$$dest; \
- fi; \
+ @list='$(templates_DATA)'; for dest in $$list; do \
+ echo " $(INSTALL_DATA) $$dest $(DESTDIR)$(templatesdir)/$$dest"; \
+ $(INSTALL_DATA) $$dest $(DESTDIR)$(templatesdir)/$$dest; \
done
clean-local: