freebsd-ports/french/med/files/patch-src::cfi::Makefile.in
2006-01-15 23:15:21 +00:00

19 lines
904 B
Text

--- src/cfi/Makefile.in.orig Tue Aug 30 10:20:16 2005
+++ src/cfi/Makefile.in Mon Jan 9 21:10:56 2006
@@ -60,11 +60,13 @@
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)/include/med
depcomp = $(SHELL) $(top_srcdir)/config/depcomp
am__depfiles_maybe = depfiles
+# FreeBSD patch: put AM_CFLAGS before CPPFLAGS to be able to compile
+# even if includes from previous version are installed.
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
- $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ $(AM_CFLAGS) $(CPPFLAGS) $(CFLAGS)
LTCOMPILE = $(LIBTOOL) --tag=CC --mode=compile $(CC) $(DEFS) \
- $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
- $(AM_CFLAGS) $(CFLAGS)
+ $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(AM_CFLAGS) \
+ $(CPPFLAGS) $(CFLAGS)
CCLD = $(CC)
LINK = $(LIBTOOL) --tag=CC --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@