freebsd-ports/devel/ice/files/patch-Makefile
Martin Wilke ccecfeab22 - Fix build with gcc 4.7
- Add support for clang

PR:		165702
Submitted by:	Michael Gmelin <freebsd@grem.de> (maintainer)
Feature safe:	yes
2012-03-24 15:57:39 +00:00

26 lines
597 B
Text

--- cpp.orig/Makefile 2012-03-04 21:38:42.000000000 +0100
+++ cpp/Makefile 2012-03-04 21:38:42.000000000 +0100
@@ -11,7 +11,22 @@
include $(top_srcdir)/config/Make.rules
-SUBDIRS = config src include test demo
+SUBDIRS = config src include
+
+ifeq ($(NOTESTS),)
+SUBDIRS += test
+endif
+
+ifeq ($(NODEMOS),)
+SUBDIRS += demo
+endif
+
+ifeq ($(NOPORTDOCS),)
+SUBDIRS += doc
+endif
+
+ INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_configdir)
+
INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_configdir)