freebsd-ports/x11-wm/windowmaker/files/patch-src::workspace.c
Pav Lucistnik 7d63a886d3 - Fix build on 4-stable
- Fix libwraster shared library version
- Remove a patch which is no longer needed
- Remove options which are no longer supported
- Fix pkg-plist
- Revise pkg-descr

PR:		ports/73082
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
2004-10-25 22:27:51 +00:00

27 lines
849 B
C

--- src/workspace.c.orig Fri Oct 15 06:14:43 2004
+++ src/workspace.c Sun Oct 24 22:32:02 2004
@@ -738,16 +738,20 @@
vdMouseMoveDesktop(XEvent *event, WMPoint direction)
{
static int lock = False;
- if (lock) return;
- lock = True;
Bool done = False;
Bool moved = True;
- WScreen *scr = wScreenForRootWindow(event->xcrossing.root);
- WMPoint old_pos = wmkpoint(event->xcrossing.x_root, event->xcrossing.y_root);
+ WScreen *scr;
+ WMPoint old_pos;
WMPoint step;
int x, y;
int resisted = 0;
+
+ if (lock) return;
+ lock = True;
+
+ scr = wScreenForRootWindow(event->xcrossing.root);
+ old_pos = wmkpoint(event->xcrossing.x_root, event->xcrossing.y_root);
if (XGrabPointer(dpy, event->xcrossing.window, False,
PointerMotionMask, GrabModeAsync, GrabModeAsync,