92f54efd68
swith. This allows build with threaded Tk (otherwise configure fails to use Tk). Also depend on threaded Tk by default in case of THREADS support - with non-pthread tk library it will not be stable enough - Add OPTIONS - Enable builds of non-threaded targets - Depend on X in case if X is installed, since configure does this by default. - Rename patchfiles to make portlint happy - Eliminate the number of reinplace patterns (remove duplicates, optimize) - Move manpage list in the separate files - Pass pthread flags to compiler (PTHREAD_CFLAGS/LIBS safety) - Remove some ugly hacks on setting permissions etc (eliminated by setting correct permission in COPY_TREE macros) - Eliminate duplicate entries in PLIST in case of unstalling optimized binaries, also optimize this part - Remove unused PLIST_SUB variable - Miscelanios cleanups in Makefile - Pass maintainership to submitter The following files was added: - files/man1 - files/manlinks - files/mann - files/patch-camlp4-man_Makefile - files/patch-camlp4_lib_Makefile - files/patch-ocamldoc_Makefile - files/patch-stdlib_Makefile I removed the following files: - files/patch-camlp4-man::Makefile - files/patch-camlp4::lib::Makefile - files/patch-ocamldoc::Makefile - files/patch-stdlib::Makefile Also add bsd.ocaml.mk until it will be included in Mk/ PR: ports/101122 Submitted by: Stanislav Sedov
21 lines
571 B
Text
21 lines
571 B
Text
--- ./camlp4/man/Makefile.orig Thu Jul 3 20:14:49 2003
|
|
+++ ./camlp4/man/Makefile Sun May 21 14:02:41 2006
|
|
@@ -3,7 +3,6 @@
|
|
include ../config/Makefile
|
|
|
|
TARGET=camlp4.1
|
|
-ALIASES=camlp4o.1 camlp4r.1 mkcamlp4.1 ocpp.1 camlp4o.opt.1 camlp4r.opt.1
|
|
|
|
all: $(TARGET)
|
|
|
|
@@ -18,10 +17,6 @@
|
|
if test -n '$(MANDIR)'; then \
|
|
$(MKDIR) $(MANDIR)/man1 ; \
|
|
cp $(TARGET) $(MANDIR)/man1/. ; \
|
|
- for i in $(ALIASES); do \
|
|
- rm -f $(MANDIR)/man1/$$i; \
|
|
- echo '.so man1/$(TARGET)' > $(MANDIR)/man1/$$i; \
|
|
- done; \
|
|
fi
|
|
|
|
camlp4.1: camlp4.1.tpl
|