- update firefox-esr, thunderbird and libxul to 17.0.8 - update seamonkey to 2.20 - fix plist for *-i18n Security: 0998e79d-0055-11e3-905b-0025905a4771 In collaboration with: Jan Beich <jbeich@tormail.org>
146 lines
3.9 KiB
Text
146 lines
3.9 KiB
Text
--- lib/softoken/legacydb/cdbhdl.h.orig 2009-08-31 12:33:12.000000000 +0200
|
|
+++ lib/softoken/legacydb/cdbhdl.h 2009-08-31 12:33:36.000000000 +0200
|
|
@@ -43,7 +43,8 @@
|
|
#define _CDBHDL_H_
|
|
|
|
#include "nspr.h"
|
|
-#include "mcom_db.h"
|
|
+#include <db.h>
|
|
+#include <fcntl.h>
|
|
#include "pcertt.h"
|
|
#include "prtypes.h"
|
|
|
|
|
|
--- lib/softoken/legacydb/dbmshim.c.orig 2009-08-31 10:40:23.000000000 +0200
|
|
+++ lib/softoken/legacydb/dbmshim.c 2009-08-31 10:40:35.000000000 +0200
|
|
@@ -39,7 +39,8 @@
|
|
*
|
|
* $Id: dbmshim.c,v 1.2 2007/06/13 00:24:57 rrelyea%redhat.com Exp $
|
|
*/
|
|
-#include "mcom_db.h"
|
|
+#include <db.h>
|
|
+#include <fcntl.h>
|
|
#include "secitem.h"
|
|
#include "nssb64.h"
|
|
#include "blapi.h"
|
|
--- lib/softoken/legacydb/keydb.c.orig 2009-08-31 10:40:04.000000000 +0200
|
|
+++ lib/softoken/legacydb/keydb.c 2009-08-31 10:40:08.000000000 +0200
|
|
@@ -43,7 +43,6 @@
|
|
#include "blapi.h"
|
|
#include "secitem.h"
|
|
#include "pcert.h"
|
|
-#include "mcom_db.h"
|
|
#include "secerr.h"
|
|
|
|
#include "keydbi.h"
|
|
--- lib/softoken/legacydb/keydbi.h.orig 2009-08-31 12:33:17.000000000 +0200
|
|
+++ lib/softoken/legacydb/keydbi.h 2009-08-31 12:34:13.000000000 +0200
|
|
@@ -43,5 +43,5 @@
|
|
|
|
#include "nspr.h"
|
|
#include "seccomon.h"
|
|
-#include "mcom_db.h"
|
|
+#include <db.h>
|
|
|
|
/*
|
|
* Handle structure for open key databases
|
|
--- lib/softoken/legacydb/pcertdb.c.orig 2009-08-31 10:40:52.000000000 +0200
|
|
+++ lib/softoken/legacydb/pcertdb.c 2009-08-31 10:41:26.000000000 +0200
|
|
@@ -41,7 +41,8 @@
|
|
*/
|
|
#include "lowkeyti.h"
|
|
#include "pcert.h"
|
|
-#include "mcom_db.h"
|
|
+#include <db.h>
|
|
+#include <fcntl.h>
|
|
#include "pcert.h"
|
|
#include "secitem.h"
|
|
#include "secder.h"
|
|
--- lib/softoken/legacydb/pk11db.c.orig 2009-08-31 10:40:57.000000000 +0200
|
|
+++ lib/softoken/legacydb/pk11db.c 2009-08-31 10:41:55.000000000 +0200
|
|
@@ -41,7 +41,8 @@
|
|
|
|
#include "pk11pars.h"
|
|
#include "lgdb.h"
|
|
-#include "mcom_db.h"
|
|
+#include <db.h>
|
|
+#include <fcntl.h>
|
|
#include "secerr.h"
|
|
|
|
#define FREE_CLEAR(p) if (p) { PORT_Free(p); p = NULL; }
|
|
--- lib/ckfw/dbm/ckdbm.h.orig 2009-08-31 10:46:00.000000000 +0200
|
|
+++ lib/ckfw/dbm/ckdbm.h 2009-08-31 10:46:22.000000000 +0200
|
|
@@ -59,7 +59,7 @@
|
|
#include "ckt.h"
|
|
#endif /* CKT_H */
|
|
|
|
-#include "mcom_db.h"
|
|
+#include <db.h>
|
|
|
|
NSS_EXTERN_DATA NSSCKMDInstance nss_dbm_mdInstance;
|
|
|
|
--- lib/softoken/legacydb/config.mk.orig 2009-08-31 12:39:49.000000000 +0200
|
|
+++ lib/softoken/legacydb/config.mk 2009-08-31 12:40:03.000000000 +0200
|
|
@@ -40,7 +40,6 @@
|
|
|
|
EXTRA_LIBS += \
|
|
$(CRYPTOLIB) \
|
|
- $(DIST)/lib/$(LIB_PREFIX)dbm.$(LIB_SUFFIX) \
|
|
$(NULL)
|
|
|
|
# can't do this in manifest.mn because OS_TARGET isn't defined there.
|
|
--- lib/certdb/xauthkid.c.orig 2009-08-31 12:43:13.000000000 +0200
|
|
+++ lib/certdb/xauthkid.c 2009-08-31 12:44:21.000000000 +0200
|
|
@@ -39,7 +39,7 @@
|
|
*
|
|
*/
|
|
|
|
-#include "prtypes.h"
|
|
+#include <prtypes.h>
|
|
#include "seccomon.h"
|
|
#include "secdert.h"
|
|
#include "secoidt.h"
|
|
--- lib/certdb/xbsconst.c.orig 2009-08-31 12:43:22.000000000 +0200
|
|
+++ lib/certdb/xbsconst.c 2009-08-31 12:44:41.000000000 +0200
|
|
@@ -38,7 +38,7 @@
|
|
* X.509 v3 Basic Constraints Extension
|
|
*/
|
|
|
|
-#include "prtypes.h"
|
|
+#include <prtypes.h>
|
|
#include <limits.h> /* for LONG_MAX */
|
|
#include "seccomon.h"
|
|
#include "secdert.h"
|
|
--- lib/certdb/xconst.c.orig 2009-08-31 12:43:46.000000000 +0200
|
|
+++ lib/certdb/xconst.c 2009-08-31 12:44:50.000000000 +0200
|
|
@@ -38,7 +38,7 @@
|
|
* X.509 Extension Encoding
|
|
*/
|
|
|
|
-#include "prtypes.h"
|
|
+#include <prtypes.h>
|
|
#include "seccomon.h"
|
|
#include "secdert.h"
|
|
#include "secoidt.h"
|
|
--- lib/manifest.mn~
|
|
+++ lib/manifest.mn
|
|
@@ -20,7 +20,7 @@ DIRS = \
|
|
$(UTIL_SRCDIR) \
|
|
$(FREEBL_SRCDIR) \
|
|
$(SQLITE_SRCDIR) \
|
|
- $(DBM_SRCDIR) \
|
|
+ $(NULL) \
|
|
$(SOFTOKEN_SRCDIR) \
|
|
base dev pki \
|
|
libpkix \
|
|
--- cmd/platlibs.mk.orig 2009-08-31 12:57:13.000000000 +0200
|
|
+++ cmd/platlibs.mk 2009-08-31 12:57:29.000000000 +0200
|
|
@@ -85,7 +85,7 @@
|
|
ifdef NSS_DISABLE_DBM
|
|
DBMLIB = $(NULL)
|
|
else
|
|
-DBMLIB = $(DIST)/lib/$(LIB_PREFIX)dbm.$(LIB_SUFFIX)
|
|
+DBMLIB = $(NULL)
|
|
endif
|
|
|
|
ifdef USE_STATIC_LIBS
|