freebsd-ports/audio/stymulator/files/patch-stsoundlib__lzh__Makefile
2010-04-23 12:06:32 +00:00

20 lines
396 B
Text

--- ./stsoundlib/lzh/Makefile.orig 2010-04-23 13:49:47.000000000 +0200
+++ ./stsoundlib/lzh/Makefile 2010-04-23 13:49:47.000000000 +0200
@@ -1,14 +1,14 @@
-CC = gcc
+CC ?= gcc
AR = ar cr
RM = rm -f
-CFLAGS = -Wall
+CFLAGS ?= -Wall
liblzh.a: lzhlib.o
$(AR) liblzh.a lzhlib.o
lzhlib.o: lzhlib.cpp lzh.h
- $(CC) -c lzhlib.cpp
+ $(CC) $(CFLAGS) -c lzhlib.cpp
clean:
$(RM) *~ *.o *.a