freebsd-ports/games/uhexen2/files/patch-hexen2__Makefile
Alejandro Pulver d6c500a87f - Update to version 1.4.2.
- Fix launcher Makefile (stock one was not working) [1].

PR:		ports/117048
Submitted by:	Pedro F. Giffuni <giffunip@tutopia.com>
Reworked by:	alepulver [1]
2007-10-21 17:51:02 +00:00

37 lines
971 B
Text

--- hexen2/Makefile.orig Sat Sep 15 09:16:44 2007
+++ hexen2/Makefile Mon Oct 8 15:56:50 2007
@@ -113,13 +113,13 @@
USE_SDLAUDIO=yes
USE_MIDI=yes
USE_CDAUDIO=yes
-USE_SDLCD=no
+USE_SDLCD=yes
WITH_SPLASHES=yes
LINK_DIRECTX=no
OPT_EXTRA=yes
LINK_GL_LIBS=no
USE_3DFXGAMMA=yes
-USE_X86_ASM=yes
+USE_X86_ASM?=no
COMPILE_32BITS=no
# build environment sanity checks
@@ -176,7 +176,7 @@
else
-CFLAGS := $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
+CFLAGS := $(CFLAGS) $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
ifdef NO_UNIT_AT_A_TIME
CFLAGS := $(CFLAGS) $(call check_gcc,-fno-unit-at-a-time,)
@@ -184,7 +184,9 @@
ifeq ($(OPT_EXTRA),yes)
# Note: re-check these flags for non-ia32 machines
+ifeq ($(MACH_TYPE),x86)
CFLAGS := $(CFLAGS) $(call check_gcc,-falign-loops=2 -falign-jumps=2 -falign-functions=2,-malign-loops=2 -malign-jumps=2 -malign-functions=2)
+endif
CFLAGS := $(CFLAGS) -fomit-frame-pointer
endif
endif