f83159f188
List of vulnerabilities is documented on: http://vuxml.freebsd.org/freebsd/8c2b2f11-0ebe-11e6-b55e-b499baebfeaf.html CVE IDs see below. PR: 206998 Submitted by: mokhi64@gmail.com (maintainer) Reviewed by: rootservice@gmail.com Approved by: mokhi64@gmail.com (maintainer) MFH: 2016Q2 Security: CVE-2016-0705 CVE-2016-0639 CVE-2015-3194 CVE-2016-0640 CVE-2016-0641 CVE-2016-3461 CVE-2016-2047 CVE-2016-0642 CVE-2016-0643 CVE-2016-0644 CVE-2016-0646 CVE-2016-0647 CVE-2016-0648 CVE-2016-0649 CVE-2016-0650 CVE-2016-0652 CVE-2016-0653 CVE-2016-0654 CVE-2016-0655 CVE-2016-0656 CVE-2016-0657 CVE-2016-0658 CVE-2016-0651 CVE-2016-0659 CVE-2016-0661 CVE-2016-0662 CVE-2016-0663 CVE-2016-0665 CVE-2016-0666 CVE-2016-0667 CVE-2016-0668
29 lines
1 KiB
Text
29 lines
1 KiB
Text
--- libmysql/CMakeLists.txt.orig 2016-03-28 18:06:12 UTC
|
|
+++ libmysql/CMakeLists.txt
|
|
@@ -215,7 +215,7 @@ IF(WIN32)
|
|
ENDIF()
|
|
|
|
# Merge several convenience libraries into one big mysqlclient
|
|
-MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development)
|
|
+MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development NOINSTALL)
|
|
|
|
# Visual Studio users need debug static library for debug projects
|
|
IF(MSVC)
|
|
@@ -257,7 +257,8 @@ IF(NOT DISABLE_SHARED)
|
|
# and link them together into shared library.
|
|
MERGE_LIBRARIES(libmysql SHARED ${LIBS}
|
|
EXPORTS ${CLIENT_API_FUNCTIONS} ${CLIENT_API_FUNCTIONS_UNDOCUMENTED}
|
|
- COMPONENT SharedLibraries)
|
|
+ COMPONENT SharedLibraries NOINSTALL)
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
# libtool compatability
|
|
IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
|
|
@@ -313,6 +314,7 @@ ENDIF()
|
|
# to initialize api_calls[] array in api_test.c
|
|
#
|
|
SET(CLIENT_API_FUNCTION_LIST "")
|
|
+ ENDIF()
|
|
FOREACH(api ${CLIENT_API_FUNCTIONS})
|
|
SET(CLIENT_API_FUNCTION_LIST "${CLIENT_API_FUNCTION_LIST} ${api},")
|
|
ENDFOREACH()
|