freebsd-ports/audio/gnome-audio/files/patch-aa
Steve Price 31f187ed60 Honor $(PREFIX) on install.
PR:		12781 (5 of 19)
Submitted by:	Ade Lovett <ade@lovett.com>
1999-08-22 03:44:30 +00:00

22 lines
766 B
Text

--- sounds/Makefile.orig Wed Feb 24 14:19:09 1999
+++ sounds/Makefile Mon Jul 12 11:24:27 1999
@@ -1,15 +1,13 @@
-prefix=$(shell gnome-config --prefix)
-
all:
install: install-files install-default-links
install-files:
for I in $(shell find . -name '*.wav'); do \
- install -d $(prefix)/share/sounds/`dirname $$I`; \
- install -m444 $$I $(prefix)/share/sounds/$$I; \
+ mkdir -p $(PREFIX)/share/gnome/sounds/`dirname $$I`; \
+ ${INSTALL_DATA} $$I $(PREFIX)/share/gnome/sounds/$$I; \
done
install-default-links:
- ln -sf startup3.wav $(prefix)/share/sounds/login.wav
- ln -sf shutdown1.wav $(prefix)/share/sounds/logout.wav
+ ln -sf startup3.wav $(PREFIX)/share/gnome/sounds/startup.wav
+ ln -sf shutdown1.wav $(PREFIX)/share/gnome/sounds/logout.wav