freebsd-ports/security/newpki-client/files/patch-configure
Pav Lucistnik 64b73b6642 NewPKI is a PKI based on the OpenSSL low-level API, all the datas are handled
through a database, which provides a much more flexible PKI than with OpenSSL,
such as seeking a certificate with a search engine.

GUI client that uses wxWidgets.

PR:		ports/83386
Submitted by:	Vsevolod Stakhov <vsevolod@highsecure.ru>
2005-07-14 13:24:04 +00:00

62 lines
1.7 KiB
Text

--- configure.in Wed Jul 6 18:52:02 2005
+++ configure Wed Jul 6 18:53:03 2005
@@ -10798,48 +10798,6 @@
fi
-# Extract the first word of "wx-config", so it can be a program name with args.
-set dummy wx-config; ac_word=$2
-echo "$as_me:$LINENO: checking for $ac_word" >&5
-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
-if test "${ac_cv_prog_WXCONFIG+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- if test -n "$WXCONFIG"; then
- ac_cv_prog_WXCONFIG="$WXCONFIG" # Let the user override the test.
-else
-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_prog_WXCONFIG=""yes""
- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
-done
-
- test -z "$ac_cv_prog_WXCONFIG" && ac_cv_prog_WXCONFIG=""no""
-fi
-fi
-WXCONFIG=$ac_cv_prog_WXCONFIG
-if test -n "$WXCONFIG"; then
- echo "$as_me:$LINENO: result: $WXCONFIG" >&5
-echo "${ECHO_T}$WXCONFIG" >&6
-else
- echo "$as_me:$LINENO: result: no" >&5
-echo "${ECHO_T}no" >&6
-fi
-
-if test x"$WXCONFIG" != x"yes"; then
- { { echo "$as_me:$LINENO: error: wx-config not found" >&5
-echo "$as_me: error: wx-config not found" >&2;}
- { (exit 1); exit 1; }; }
-fi
-
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'
ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
@@ -10848,8 +10806,8 @@
-WXCXX=`wx-config --cxxflags`
-WXLIB=`wx-config --libs`
+WXCXX=`${WXCONFIG} --cxxflags`
+WXLIB=`${WXCONFIG} --libs`
CPPFLAGS="$WXCXX -DWXINTL_NO_GETTEXT_MACRO $CPPFLAGS"
LIBS="$WXLIB -lnewpki $LIBS"