* this release switched the build system to cmake * move libproxy-gnome to libproxy-gnome2 for consistency * add new slave libproxy-webkit3 * try to simplify the whole thing * bump revisions in the dependencies Reviewed by: gnome (kwm), mat Differential Revision: https://reviews.freebsd.org/D15655
18 lines
539 B
Text
18 lines
539 B
Text
Only build the library in the master port.
|
|
|
|
--- bindings/CMakeLists.txt.orig 2017-05-11 09:33:33 UTC
|
|
+++ bindings/CMakeLists.txt
|
|
@@ -20,6 +20,7 @@ if (WITH_PERL)
|
|
endif()
|
|
|
|
# Install Vala bindings / Install only when -DWITH_VALA is passed to cmake.
|
|
+if (WITH_LIBRARY)
|
|
option(WITH_VALA "Enables Vala bindings" OFF)
|
|
if(WITH_VALA)
|
|
if (NOT VAPI_DIR)
|
|
@@ -27,4 +28,5 @@ if(WITH_VALA)
|
|
endif()
|
|
install(FILES vala/libproxy-1.0.vapi DESTINATION ${VAPI_DIR})
|
|
set(VAPI_DIR ${VAPI_DIR} CACHE PATH "Vala API directory")
|
|
+endif()
|
|
endif()
|