daf9bed6c4
- Respect CFLAGS [2] - Support parallel port under FreeBSD [3] PR: ports/102154 [1], ports/102188 [2] Submitted by: Juergen Lock <nox@jelal.kn-bremen.de> [1], Stanislav Sedov <ssedov@mbsd.msk.ru> [2], Robert Jenssen (via freebsd-ports) [3] Approved by: Juergen Lock <nox@jelal.kn-bremen.de> (maintainer) [2] [3]
31 lines
791 B
Text
31 lines
791 B
Text
Index: qemu/Makefile.target
|
|
@@ -404,7 +404,9 @@
|
|
ifndef CONFIG_DARWIN
|
|
ifndef CONFIG_WIN32
|
|
ifndef CONFIG_SOLARIS
|
|
-VL_LIBS=-lutil -lrt
|
|
+#VL_LIBS=-lutil -lrt
|
|
+# XXX this cant be just merged back...
|
|
+VL_LIBS=-lutil
|
|
endif
|
|
endif
|
|
endif
|
|
Index: qemu/vl.c
|
|
@@ -541,7 +541,7 @@
|
|
static void init_get_clock(void)
|
|
{
|
|
use_rt_clock = 0;
|
|
-#if defined(__linux__)
|
|
+#if defined(__linux__) || (defined(__FreeBSD__) && __FreeBSD_version >= 500000)
|
|
{
|
|
struct timespec ts;
|
|
if (clock_gettime(CLOCK_MONOTONIC, &ts) == 0) {
|
|
@@ -553,7 +553,7 @@
|
|
|
|
static int64_t get_clock(void)
|
|
{
|
|
-#if defined(__linux__)
|
|
+#if defined(__linux__) || (defined(__FreeBSD__) && __FreeBSD_version >= 500000)
|
|
if (use_rt_clock) {
|
|
struct timespec ts;
|
|
clock_gettime(CLOCK_MONOTONIC, &ts);
|