freebsd-ports/www/py-aiohttp/files/patch-setup.py
Kubilay Kocak fd863091ec www/py-aiohttp: Update to 3.5.4
- Drop use of cython, only needed for 'from git' builds
  - Document necessary but not-yet-ported TEST_DEPENDS for our future selves
    and potential contributors to see.
  - Update port metadata to match upstream: pkg-desc, WWW URL, LICENSE, COMMENT
  - Patch setup.py: Add necessary but missing entries to tests_require. For the
    ones not yet ported, they're fetched from PyPI via setuptools when correctly
    declared. Move pytest min version requirement from pytest.ini to
    tests_require where it belongs, so it can be parsed and the right version
    can be fetched, instead of just failing if its not the required version.
  - Patch pytest.ini: Strip --cov from pytest args. We don't care about coverage
    downstream, and it shouldnt be a compulsory (tests_require) dependency, but
    instead an extras_require, so dont add it to TEST_DEPENDS even though it is
    a port.

Changelog:

  https://github.com/aio-libs/aiohttp/blob/v3.5.4/CHANGES.rst

PR:	228575
2019-03-26 13:38:59 +00:00

16 lines
395 B
Python

--- setup.py.orig 2019-01-12 10:13:41 UTC
+++ setup.py
@@ -104,9 +104,12 @@ NEEDS_PYTEST = {'pytest', 'test'}.intersection(sys.arg
pytest_runner = ['pytest-runner'] if NEEDS_PYTEST else []
tests_require = [
- 'pytest', 'gunicorn',
+ 'pytest>=3.8.2', 'gunicorn',
'pytest-timeout', 'async-generator',
'pytest-xdist',
+ 'pytest-mock',
+ 'trustme',
+ 'brotlipy',
]