freebsd-ports/mail/thunderbird3/files/patch-jsosdep
Jeremy Messenger 48c35e710c - Repo copy a lot of changes from www/firefox/Makefile. The best part is that
before it would install in the strange place like this.

  	${X11BASE}/lib/thunderbird/include/thunderbird-1.0.6

  Now it will install in the correct place like firefox:

	${X11BASE}/include/thunderbird

  Also, get *.pc and idl files install.
- Didn't copy following from www/firefox/Makefile:
	* plugins stuff, because it's known cause the stability problem like
  	  crash.
	* EXTRA_SCRIPTS=${PORTNAME}.rb, thunderbird doesn't need it.
- Make portlint happier.
- Add Java 5 plugins support. [1]
- Use system's libm (/usr/src/lib/msun), nss, nspr and etc. Also, do
  not extract those. Better explain, use external dependencies. [1]
- Teach firefox-config and *.pc files for nspr that will making other
  third apps to buildable like epiphany, vlc-devel's mozilla plugins
  and etc. Have been tested with full GNOME 2.11.x build too.
- Add four patches: [1]

	patch-bugzilla243151:
		https://bugzilla.mozilla.org/show_bug.cgi?id=243151

	patch-jsosdep:
		Fix the FreeBSD define

	patch-oji-threads:
		64-bit wide pthread_t

	patch-xptcinvoke_x86_64_linux:
		Setting a possibly uninitialized variable (value).

- Fix a crash that can occur using gtk+-2.7 and possibly 2.6.10 when closing
  windows. https://bugzilla.mozilla.org/show_bug.cgi?id=3002 [2]
- Get rid of FIREFOX and FF_VER, best to use PORTNAME and PORTVERSION
  varibles that are arleady exist and lesser complicate.
- Change all hardcore of 'thunderbird' to PORTNAME.
- Change a manual loop for patch all.js to find(1), so we can sleep
  on it.

Submitted by:	mi [1], marcus [2]
Reviewed by:	my team, FreeBSD GNOME Team.
2005-08-28 08:00:00 +00:00

9 lines
242 B
Text

--- js/src/jsosdep.h Fri Nov 14 19:10:59 2003
+++ js/src/jsosdep.h Fri Aug 5 00:50:44 2005
@@ -102,5 +102,5 @@
#define JS_HAVE_LONG_LONG
-#elif defined(FREEBSD)
+#elif defined(FREEBSD) || defined(__FreeBSD__)
#define JS_HAVE_LONG_LONG