d587b3a37a
The new release includes performance improvements and advanced SQL features which will support bigger data warehouses, higher-volume transaction processing, and more complex distributed enterprise software. Major new features in this release include: Roles: PostgreSQL now supports database roles, which simplify the management of large numbers of users with complex overlapping database rights. IN/OUT Parameters: PostgreSQL functions now support IN, OUT and INOUT parameters, which substantially improves support of complex business logic for J2EE and .NET applications. Two-Phase Commit (2PC): Long in demand for WAN applications and heterogeneous data centers using PostgreSQL, this feature allows ACID-compliant transactions across widely separated servers. Some Performance Enhancements found in this release include: Improved Multiprocessor (SMP) Performance: The buffer manager for 8.1 has been enhanced to scale almost linearly with the number of processors, leading to significant performance gains on 8-way, 16-way, dual-core, and multi-core CPU servers. Bitmap Scan: Indexes will be dynamically converted to bitmaps in memory when appropriate, giving up to twenty times faster index performance on complex queries against very large tables. Table Partitioning: The query planner is now able to avoid scanning whole sections of a large table using a technique known as Constraint Exclusion. Shared Row Locking: PostgreSQL's "better than row-level locking" now supports even higher levels of concurrency through the addition of shared row locks for foreign keys. For a more complete listing of changes in this release, please see the Release Notes visible at: http://www.postgresql.org/docs/current/static/release.html#RELEASE-8-1
8 lines
199 B
Text
8 lines
199 B
Text
--- src/makefiles/Makefile.freebsd.orig Fri Nov 19 01:41:39 2004
|
|
+++ src/makefiles/Makefile.freebsd Tue Dec 21 02:44:09 2004
|
|
@@ -29,3 +29,5 @@
|
|
endif
|
|
|
|
sqlmansect = 7
|
|
+
|
|
+allow_nonpic_in_shlib = yes
|