freebsd-ports/archivers/par2cmdline/files/patch-Makefile.am
Ganael LAPLANCHE b0525991c8 Change upstream and update to much newer version 0.8.1
A test target has also been added to the port.

Changelog: https://github.com/Parchive/par2cmdline/blob/master/ChangeLog

PR:		248681
Submitted by:	Paul Holmanskikh <freebsd@pkholm.com>
2020-08-19 10:10:37 +00:00

21 lines
781 B
Text

Install relative symlinks instead of absolute ones.
This is useful when installing into a staging directory to avoid getting links
temporarily pointing out of that directory.
--- Makefile.am.orig 2020-02-09 14:53:55 UTC
+++ Makefile.am
@@ -168,9 +168,10 @@ TESTS = tests/test1 \
tests/unit_tests
install-exec-hook :
- ln -sf $(bindir)/par2$(EXEEXT) $(DESTDIR)$(bindir)/par2create$(EXEEXT)
- ln -sf $(bindir)/par2$(EXEEXT) $(DESTDIR)$(bindir)/par2verify$(EXEEXT)
- ln -sf $(bindir)/par2$(EXEEXT) $(DESTDIR)$(bindir)/par2repair$(EXEEXT)
+ cd $(DESTDIR)$(bindir)/ && \
+ ln -sf par2$(EXEEXT) par2create$(EXEEXT) && \
+ ln -sf par2$(EXEEXT) par2verify$(EXEEXT) && \
+ ln -sf par2$(EXEEXT) par2repair$(EXEEXT)
uninstall-hook :
rm -f $(DESTDIR)$(bindir)/par2create$(EXEEXT)