default gcc version change when USE_FORTRAN=yes. Patches included from http://bugs.gentoo.org/show_bug.cgi?id=318045. [1] - Renamed and conditionalized some patches to support tgammaf function on OSVERSION < 800023. Previously, it was included even when present in the system math library. Also fixed name-mangling problem in the patches. Declarations were wrapped in 'extern "C"', but the definitions were not, causing a linker error. - Added a patch to CMakeLists.txt to prevent cmake from changing rpath during the installation phase. That caused libstdc++ from /usr/lib to be used instead of the one supplied with gcc 4.5. Requested by: gerald [1]
11 lines
464 B
C++
11 lines
464 B
C++
--- ./libs/libFreeMat/Array.cpp.orig 2009-10-09 02:24:20.000000000 -0400
|
|
+++ ./libs/libFreeMat/Array.cpp 2010-09-21 14:32:02.000000000 -0400
|
|
@@ -465,7 +465,7 @@
|
|
|
|
void Array::set(const QString& field, ArrayVector& data) {
|
|
if (isEmpty() && m_type.Class != Struct)
|
|
- *this = Array::Array(Struct);
|
|
+ *this = Array(Struct);
|
|
if (m_type.Class != Struct) throw Exception("Unsupported type for A.field=B");
|
|
StructArray &rp(structPtr());
|
|
if (isEmpty())
|