relayd is a daemon to relay and dynamically redirect incoming connections to a target host. Its main purposes are to run as a load-balancer, application layer gateway, or transparent proxy. The daemon is able to monitor groups of hosts for availability, which is determined by checking for a specific service common to a host group. WWW: http://spootnik.org/relayd/ # This port will work on $OSVERSION >= 700049. # If you want to use on RELENG_6, apply a patch in # http://www.openbsd.org/cgi-bin/cvsweb/src/sys/net/pf_table.c.diff?r1=1.67&r2=1.68
20 lines
611 B
Text
20 lines
611 B
Text
--- relayctl/Makefile.orig Tue Jan 9 09:45:32 2007
|
|
+++ relayctl/Makefile Wed Jun 6 18:58:57 2007
|
|
@@ -8,9 +8,16 @@
|
|
MAN= relayctl.8
|
|
|
|
CFLAGS+= -Wall -Werror -I${.CURDIR} -I${.CURDIR}/../relayd
|
|
+CFLAGS+= -I${PREFIX}/include -D__dead=''
|
|
CFLAGS+= -Wstrict-prototypes -Wmissing-prototypes
|
|
CFLAGS+= -Wmissing-declarations
|
|
CFLAGS+= -Wshadow -Wpointer-arith -Wcast-qual
|
|
-CFLAGS+= -Wsign-compare -Wbounded
|
|
+CFLAGS+= -Wsign-compare
|
|
+
|
|
+install:
|
|
+ $(INSTALL) -m 555 -g wheel -o root relayctl $(PREFIX)/sbin
|
|
+
|
|
+install-man:
|
|
+ $(INSTALL) -o root -g wheel -m 444 relayctl.8 $(PREFIX)/man/man8
|
|
|
|
.include <bsd.prog.mk>
|