freebsd-ports/x11/kdelibs4/files/patch-kio_kfile_kpropertiesdialog.cpp
Max Brazhnikov 1f8475f22f Mk/bsd.kde4.mk:
- rework KDE4_BUILDENV

All ports:
- remove needless post-extract target
- make patches relative to ${PATCH_WRKSRC}
- clean up
- bump PORTREVISION when required

databases/akonadi:
- replace dependency on boost-python-libs with boost-libs
  (finally, boost-pyhton does not conflict with boost \o/)

deskutils/kdepim*:
- replace boost-python-libs with boost-libs
- reduce dependencies
- respect PREFIX
- fix build with qt3 installed

misc/kdeedu4:
- add dependency on astro/xplanet (for KStars)

misc/kdeutils4:
- add dependency on devel/qca (for okteta)
- make dependency on kdebase non-optional

multimedia/kdemultimedia4:
- add optional support for PulseAudio

x11/kdebase4:
- remove needless dependency on kdebase4-runtime

x11/kdebase4-runtime, x11/kdebase4-workspace
- remove extra CMAKE_ARGS to fix build for qt3/kde3 users

x11/kdelibs4
- remove needless dependencies
- remove extra CMAKE_ARGS to fix build for qt3/kde3 users
2009-08-10 11:47:36 +00:00

18 lines
691 B
C++

--- ./kio/kfile/kpropertiesdialog.cpp.orig 2009-05-06 14:14:38.000000000 +0400
+++ ./kio/kfile/kpropertiesdialog.cpp 2009-05-30 00:46:08.000000000 +0400
@@ -1804,7 +1804,15 @@
#else
QVarLengthArray<gid_t> groups;
#endif
+#ifdef Q_OS_FREEBSD
+#include <osreldate.h>
+#endif
+#if defined(Q_OS_FREEBSD) && (__FreeBSD_version <= 800000) // Fixed in kern/114655
+ gid_t tmp_group;
+ if (getgrouplist(strUser, user->pw_gid, &tmp_group, &groupCount) < 0) {
+#else
if (getgrouplist(strUser, user->pw_gid, NULL, &groupCount) < 0) {
+#endif
groups.resize(groupCount);
if (groups.data())
getgrouplist(strUser, user->pw_gid, groups.data(), &groupCount);