e71f54cc47
- I forget to add etc/rc.d/slash.sh in pkg-plist (which will not added during 'port test') Noted by: krismail
50 lines
1.7 KiB
Text
50 lines
1.7 KiB
Text
--- Makefile.orig Wed Jul 3 17:22:34 2002
|
|
+++ Makefile Tue Mar 8 10:57:41 2005
|
|
@@ -62,7 +62,7 @@
|
|
slash:
|
|
@echo "=== INSTALLING SLASH MODULES ==="
|
|
@if [ ! "$(RPM)" ] ; then \
|
|
- (cd Slash; $(PERL) Makefile.PL; make install UNINST=1); \
|
|
+ (cd Slash; $(PERL) Makefile.PL PREFIX=$(PREFIX); make all pure_install UNINST=1); \
|
|
else \
|
|
echo " - Performing an RPM build"; \
|
|
(cd Slash; $(PERL) Makefile.PL INSTALLSITEARCH=$(INSTALLSITEARCH) INSTALLSITELIB=$(INSTALLSITELIB) INSTALLMAN3DIR=$(INSTALLMAN3DIR); make install UNINST=1); \
|
|
@@ -76,8 +76,8 @@
|
|
echo == $$PWD; \
|
|
if [ -f Makefile.PL ]; then \
|
|
if [ ! "$(RPM)" ] ; then \
|
|
- $(PERL) Makefile.PL; \
|
|
- make install UNINST=1;\
|
|
+ $(PERL) Makefile.PL PREFIX=$(PREFIX); \
|
|
+ make all pure_install UNINST=1;\
|
|
else \
|
|
echo " - Performing an RPM build."; \
|
|
$(PERL) Makefile.PL INSTALLSITEARCH=$(INSTALLSITEARCH) INSTALLSITELIB=$(INSTALLSITELIB) INSTALLMAN3DIR=$(INSTALLMAN3DIR); \
|
|
@@ -86,7 +86,7 @@
|
|
fi); \
|
|
done)
|
|
|
|
-all: install
|
|
+all:
|
|
|
|
install: slash plugins
|
|
|
|
@@ -167,15 +167,11 @@
|
|
if [ -d $(INIT) ]; then \
|
|
init=$(INIT); \
|
|
fi; \
|
|
- elif [ -d /etc/init.d ]; then \
|
|
- init=/etc; \
|
|
- elif [ -d /etc/rc.d/init.d ]; then \
|
|
- init=/etc/rc.d; \
|
|
+ elif [ -d $(PREFIX)/etc/rc.d ]; then \
|
|
+ init=$(PREFIX)/etc/rc.d; \
|
|
fi; \
|
|
if [ $$init ]; then \
|
|
- $(INSTALL) utils/slash $$init/init.d/; \
|
|
- ln -s -f ../init.d/slash $$init/rc3.d/S99slash; \
|
|
- ln -s -f ../init.d/slash $$init/rc6.d/K99slash; \
|
|
+ $(INSTALL) utils/slash $$init/slash.sh; \
|
|
else \
|
|
echo "*** Makefile can't determine where your init scripts live."; \
|
|
if [ $$init ]; then \
|