90410e570d
- print/texlive-infra was renamed with print/texlive-tlmgr. Note that currently tlmgr(1) does not work because of lack of TLPDB. This will be fixed. - Lua libraries used in LuaTeX are separated into devel/tex-libtexlua and devel/texlibtexluajit. USE_TEX supports them via keywords "texlua" and "texluajit". - libsynctex is currently installed by devel/tex-web2c. This will be separated into a single port. - Add graphics/libpotrace and use installed libpotrace and libharfbuzz.
27 lines
860 B
Text
27 lines
860 B
Text
--- texk/xdvik/configure.ac.orig 2014-04-13 03:58:39 UTC
|
|
+++ texk/xdvik/configure.ac
|
|
@@ -67,6 +67,16 @@ AS_IF([test "x$enable_a4" = xno],
|
|
[AC_MSG_NOTICE([Disabled a4/cm, using letter/in instead])],
|
|
[AC_DEFINE([A4], 1, [Define to use A4 as the default paper size.])])
|
|
|
|
+dnl Kanji support
|
|
+AC_DEFINE([PTEX], 1, [Enabled Japanese pTeX support.])
|
|
+if pkg-config fontconfig --modversion > /dev/null 2>&1; then
|
|
+ AC_MSG_RESULT(adding fontconfig-`pkg-config fontconfig --modversion` library)
|
|
+ FONTCONFIGCPPFLAGS="`pkg-config fontconfig --cflags`"
|
|
+ LIBS="`pkg-config fontconfig --libs` $LIBS"
|
|
+ AC_SUBST(FONTCONFIGCPPFLAGS)
|
|
+ AC_DEFINE(HAVE_FONTCONFIG, 1, [Using fontconfig])
|
|
+fi
|
|
+
|
|
AC_CONFIG_HEADERS([c-auto.h:c-auto.in])
|
|
|
|
AC_FUNC_FORK
|
|
@@ -263,6 +273,7 @@ fi
|
|
|
|
KPSE_KPATHSEA_FLAGS
|
|
KPSE_FREETYPE2_FLAGS
|
|
+KPSE_ZLIB_FLAGS
|
|
|
|
XDVI_GS_LIB_PATH
|
|
|