freebsd-ports/audio/openal-soft/files/patch-CMakeLists.txt
Tobias Kortkamp 50346552a3 audio/openal-soft: Cleanup options
- Drop bogus FLUIDSYNTH option (MIDI support was removed in 1.17.0)
- The sndio backend is missing capture support.  This can lead to crashes
  when there is no usable fallback backend available.  As a workaround
  always enable the OSS backend when the sndio backend is wanted.
- Prioritize sndio over OSS when it's enabled which should
  make it unnecessary to fiddle with config files when building
  with both SNDIO and OSS.
- Turn off dynamically loading backend libs via dlopen
- Correct lib depends
- Update pkg-descr
- Take maintainership
2018-06-21 06:32:16 +00:00

29 lines
1.1 KiB
Text

--- CMakeLists.txt.orig 2017-09-24 13:41:50 UTC
+++ CMakeLists.txt
@@ -1381,7 +1381,7 @@ endif()
# Install alsoft.conf configuration file
IF(ALSOFT_CONFIG)
INSTALL(FILES alsoftrc.sample
- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft
)
MESSAGE(STATUS "Installing sample configuration")
MESSAGE(STATUS "")
@@ -1391,7 +1391,7 @@ ENDIF()
IF(ALSOFT_HRTF_DEFS)
INSTALL(FILES hrtf/default-44100.mhr
hrtf/default-48000.mhr
- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal/hrtf
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft/hrtf
)
MESSAGE(STATUS "Installing HRTF definitions")
MESSAGE(STATUS "")
@@ -1405,7 +1405,7 @@ IF(ALSOFT_AMBDEC_PRESETS)
presets/rectangle.ambdec
presets/square.ambdec
presets/presets.txt
- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal/presets
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft/presets
)
MESSAGE(STATUS "Installing AmbDec presets")
MESSAGE(STATUS "")