freebsd-ports/net-im/zephyr/files/patch-zhm__Makefile.in
Tijl Coosemans 216b5a285f - Fix missing library problems when the linker enforces explicit linking
PR:		192062
Exp-run by:	antoine
Approved by:	portmgr (antoine)
2014-08-26 14:06:08 +00:00

18 lines
553 B
Text

--- zhm/Makefile.in.orig 2014-08-21 09:11:35 UTC
+++ zhm/Makefile.in
@@ -27,13 +27,14 @@ CFLAGS=@CFLAGS@
ALL_CFLAGS=${CFLAGS} -I${top_srcdir}/h -I${BUILDTOP}/h ${CPPFLAGS}
LDFLAGS=@LDFLAGS@
HESIOD_LIBS=@HESIOD_LIBS@
+LIBS=${LIBZEPHYR} -lcom_err ${HESIOD_LIBS} @LIBS@
OBJS= timer.o queue.o zhm.o zhm_client.o zhm_server.o
all: zhm
zhm: ${OBJS} ${LIBZEPHYR}
- ${LIBTOOL} --mode=link ${CC} ${LDFLAGS} -o $@ ${OBJS} ${LIBZEPHYR} ${HESIOD_LIBS}
+ ${LIBTOOL} --mode=link ${CC} ${LDFLAGS} -o $@ ${OBJS} ${LIBS}
.c.o:
${CC} -c ${ALL_CFLAGS} $<