The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
45 lines
1.3 KiB
Text
45 lines
1.3 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./front/src/Makefile Tue Feb 15 14:23:34 1994
|
|
+++ ./front/src/Makefile Thu Aug 5 18:49:03 2004
|
|
@@ -41,10 +41,10 @@
|
|
make -f MakefileM2C LIB=$(MLIB)
|
|
|
|
Scanner.md Scanner.mi: input.rex
|
|
- rex -d input.rex;
|
|
+ $(REX) -d input.rex;
|
|
|
|
Parser.md Parser.mi: input.lalr
|
|
- lalr -b -d input.lalr;
|
|
+ $(LALR) -b -d input.lalr;
|
|
|
|
install: ErrorTab $(LIB)/lalr
|
|
install -c -m 644 ErrorTab $(LIB)/lalr
|
|
@@ -65,9 +65,9 @@
|
|
|
|
lalrId: input.rex
|
|
echo SCANNER lalrId | cat - input.rex | \
|
|
- sed 's/\(RETURN.*Ident\)/yyEcho; IO.WriteNl (IO.StdOutput); \1/' | \
|
|
+ $(SED) 's/\(RETURN.*Ident\)/yyEcho; IO.WriteNl (IO.StdOutput); \1/' | \
|
|
$(BIN).sparc.t/rex -sd;
|
|
- sed 's/@/lalrId/' < ../../front/src/Id.mi > lalrIdDrv.mi
|
|
+ $(SED) 's/@/lalrId/' < ../../front/src/Id.mi > lalrIdDrv.mi
|
|
echo p lalrIdDrv | mc -d $(MLIB)
|
|
mv lalrIdDrv lalrId
|
|
|
|
@@ -80,13 +80,14 @@
|
|
sh -c "if test ! -d $(LIB)/Id; then mkdir -p $(LIB)/Id; else true; fi"
|
|
|
|
cleanId:
|
|
- rm -f lalrId*
|
|
+ -rm -f lalrId*
|
|
|
|
clean: cleanId
|
|
- rm -f core *.[dimor] *.def *.mod *.sym ERRORS LISTING _Debug Pars *.bak
|
|
+ -rm -f $(STDCLEAN)
|
|
+ -rm -f *.[dimor] *.def *.mod *.sym ERRORS LISTING _Debug Pars *.bak
|
|
|
|
CLEAN: clean
|
|
- rm -f Scanner* Parser*
|
|
+ -rm -f Scanner* Parser*
|
|
|
|
.SUFFIXES: .def .mod .md .mi
|
|
|