5fb10ebe97
than further patching the source Makefile) - Add LICENSE (GPLv2) - Rename patch to reflect the file it applies to - Whitespace cleanup Approved by: portmgr (blanket approval)
38 lines
1.3 KiB
Text
38 lines
1.3 KiB
Text
--- ./Makefile.orig 2014-06-19 00:53:36.000000000 -0400
|
|
+++ ./Makefile 2014-06-19 01:00:11.000000000 -0400
|
|
@@ -8,27 +8,27 @@
|
|
###################
|
|
|
|
# change this to your favorite ANSI C compiler
|
|
-CC = gcc
|
|
+CC ?= cc
|
|
|
|
# change this to the directory where you want the xtris binaries installed
|
|
-BINDIR = /usr/local/bin
|
|
+BINDIR = ${PREFIX}/bin
|
|
|
|
# change this to the directory where you want the xtris manpages installed
|
|
-MANDIR = /usr/local/man
|
|
+MANDIR = ${PREFIX}/man
|
|
|
|
# change according to taste and local custom...
|
|
-CFLAGS = -O3 -D__USE_FIXED_PROTOTYPES__ $(IPV6_CFLAGS) $(XCFLAGS)
|
|
+CFLAGS += -D__USE_FIXED_PROTOTYPES__ $(IPV6_CFLAGS) $(XCFLAGS)
|
|
|
|
# on Solaris and similar systems, you'll need to uncomment this:
|
|
EXTRALIBS = $(IPV6_LDFLAGS) #-lnsl -lsocket
|
|
|
|
# specify X11 cflags and libdir if your system needs it
|
|
-XCFLAGS = #-I/usr/X11/include
|
|
-XLIBDIR = #-L/usr/X11/lib
|
|
+XCFLAGS = -I${LOCALBASE}/include
|
|
+XLIBDIR = -L${LOCALBASE}/lib
|
|
|
|
# IPv6 Settings
|
|
-IPV6_CFLAGS = #-DINET6 #-I/usr/inet6/include
|
|
-IPV6_LDFLAGS = #-L/usr/local/v6/lib -linet6
|
|
+#IPV6_CFLAGS = #-DINET6 #-I/usr/inet6/include
|
|
+#IPV6_LDFLAGS = #-L/usr/local/v6/lib -linet6
|
|
|
|
###########################################################################
|
|
## You shouldn't need to change anything past this. ##
|