freebsd-ports/x11-toolkits/xmhtml/files/patch-ad
Jeremy Messenger 85a4f29865 -Fix the build/installation with libtool 2.2.
-Get all files/* to use '-ur' flag with diff(1). Got dizzy without -ur. :-P

Reported by:	pointyhat-exp
2009-07-12 16:46:02 +00:00

24 lines
714 B
Text

--- lib/Makefile.orig 1999-02-03 18:43:26.000000000 -0600
+++ lib/Makefile 2009-07-12 11:05:25.000000000 -0500
@@ -25,7 +25,7 @@
# Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. #
##############################################################################
#
-LIBRARY=libXmHTML.a
+LIBRARY=libXmHTML.la
# Target to make
TARGET=$(LIBRARY)
@@ -44,9 +44,9 @@
@(set -x; cd common; $(MAKE) all $(pass_flags) )
$(TARGET):: common $(PLATFORM)
- $(RM) $@ \
- $(AR) $@ common/*.o $(PLATFORM)/*.o
- $(RANLIB) $@
+ $(RM) $@
+ $(LIBTOOL) --mode=link $(CC) -o $@ common/*.lo $(PLATFORM)/*.lo \
+ -rpath ${PREFIX}/lib -version-info 1:2
depend::
@( for dir in $(SUBDIRS) ; do \