freebsd-ports/lang/spidermonkey24/files/patch-bug1046224
Koop Mast 8ba21f0052 Fix the build on ARM [1]
Add DTRACE option (default off) [2]

PR:		197058 [1]
PR:		192614 [2]
Submitted by:	sbruno@ [1], jbeich@ [2]
2015-01-30 09:58:04 +00:00

32 lines
1 KiB
Text

diff --git js/src/configure js/src/configure
index 59d69c7..779a50f 100644
--- configure
+++ configure
@@ -10260,7 +10260,13 @@ cross_compiling=$ac_cv_prog_cc_cross
# Check whether --enable-dtrace or --disable-dtrace was given.
if test "${enable_dtrace+set}" = set; then
enableval="$enable_dtrace"
- enable_dtrace="yes"
+ if test "$enableval" = "yes"; then
+ enable_dtrace="yes"
+ elif test "$enableval" = "no"; then
+ :
+ else
+ { echo "configure: error: Option, dtrace, does not take an argument ($enableval)." 1>&2; exit 1; }
+ fi
fi
if test "x$enable_dtrace" = "xyes"; then
diff --git js/src/configure.in js/src/configure.in
index 59d69c7..779a50f 100644
--- configure.in
+++ configure.in
@@ -2153,7 +2153,7 @@ dnl Quota support
MOZ_CHECK_HEADERS(sys/quota.h)
MOZ_CHECK_HEADERS(linux/quota.h)
-AC_ARG_ENABLE(dtrace,
+MOZ_ARG_ENABLE_BOOL(dtrace,
[ --enable-dtrace build with dtrace support if available (default=no)],
[enable_dtrace="yes"],)
if test "x$enable_dtrace" = "xyes"; then