Bugfix: - Improper locking during storage engine initialization could cause a server exit. - A query with a WHERE clause whose predicate contained a numeric value in scientific notation was not handled correctly. - VS2019 produced compilation errors with debug compilation selected due to use of the /ZI flag. Now /Z7 is used instead. - For MySQL Community Edition, the cipher order specified by the client was used in preference to the order on the server side, unless the server was confi - Password masking was incomplete for SHOW PROCESSLIST and some INFORMATION_SCHEMA and Performance Schema tables. - The -DWITH_EXAMPLE_STORAGE_ENGINE=1 CMake option was ignored but should not have been. If -DWITH_EXAMPLE_STORAGE_ENGINE=0 is given, the EXAMPLE storage e More Info: https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-46.html Approved by: mmokhi (maintainer, implicit) MFH: 2020Q1 Security: fc91f2ef-fd7b-11e9-a1c7-b499baebfeaf Sponsored by: Netzkommune GmbH
42 lines
1.1 KiB
Text
42 lines
1.1 KiB
Text
--- CMakeLists.txt.orig 2020-01-01 20:46:13.771078000 +0100
|
|
+++ CMakeLists.txt 2020-01-01 20:49:28.631677000 +0100
|
|
@@ -558,12 +558,10 @@ IF(UNIX)
|
|
ENDIF()
|
|
|
|
IF(NOT WITHOUT_SERVER)
|
|
- ADD_SUBDIRECTORY(tests)
|
|
ADD_SUBDIRECTORY(sql)
|
|
OPTION (WITH_EMBEDDED_SERVER "Compile MySQL with embedded server" OFF)
|
|
IF(WITH_EMBEDDED_SERVER)
|
|
ADD_SUBDIRECTORY(libmysqld)
|
|
- ADD_SUBDIRECTORY(libmysqld/examples)
|
|
ENDIF(WITH_EMBEDDED_SERVER)
|
|
ENDIF()
|
|
|
|
@@ -572,10 +570,7 @@ ENDIF()
|
|
ADD_SUBDIRECTORY(scripts)
|
|
|
|
IF(NOT WITHOUT_SERVER)
|
|
- ADD_SUBDIRECTORY(mysql-test)
|
|
- ADD_SUBDIRECTORY(mysql-test/lib/My/SafeProcess)
|
|
ADD_SUBDIRECTORY(support-files)
|
|
- ADD_SUBDIRECTORY(sql-bench)
|
|
IF(EXISTS ${CMAKE_SOURCE_DIR}/internal/CMakeLists.txt)
|
|
ADD_SUBDIRECTORY(internal)
|
|
ENDIF()
|
|
@@ -634,6 +629,7 @@ ENDIF()
|
|
#
|
|
# RPM installs documentation directly from the source tree
|
|
#
|
|
+IF(FALSE)
|
|
IF(NOT INSTALL_LAYOUT MATCHES "RPM")
|
|
INSTALL(FILES
|
|
README
|
|
@@ -652,6 +648,7 @@ IF(NOT INSTALL_LAYOUT MATCHES "RPM")
|
|
PATTERN "mysql.info" EXCLUDE
|
|
PATTERN "sp-imp-spec.txt" EXCLUDE
|
|
)
|
|
+ENDIF()
|
|
ENDIF()
|
|
|
|
INCLUDE(CPack)
|