freebsd-ports/net/net-snmp/files/patch-al
Jun Kuriyama a05aa88645 Upgrade to 5.0.2.
Remove statvfs hack.
2002-07-22 05:57:58 +00:00

29 lines
626 B
Text

--- configure.in.orig Tue May 7 08:12:10 2002
+++ configure.in Mon Jun 24 09:38:33 2002
@@ -1772,6 +1772,26 @@
AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
[
+dnl 4.4 compatible but renamed on FreeBSD
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#define KERNEL
+#define _KERNEL
+#include <sys/socket.h>
+#undef KERNEL
+#undef _KERNEL
+#include <net/route.h>
+],[
+
+#ifndef STRUCT_RTENTRY_HAS_RT_DST
+#define rt_dst rt_nodes->rn_key
+#endif
+
+ struct rtentry rt;
+ rt.rt_nodes[0].rn_bit = 1;
+ rt.rt_dst;
+ ], ac_cv_RTENTRY_TYPE="BSD-4.4")
+
dnl 4.4 compat
AC_TRY_COMPILE([
#ifdef HAVE_SYS_PARAM_H