freebsd-ports/cad/salome-yacs/files/patch-engine_Makefile.am
Philip M. Gollucci 376d6d0362 SALOME is a free software that provides a generic platform for Pre
and Post-Processing for numerical simulation.
+Supports interoperability between CAD modeling and
 computation software (CAD-CAE link)
+Makes easier the integration of new components on heterogeneous systems
 for numerical computation
+Sets the priority to multi-physics coupling between computation software
+Provides a generic user interface, user-friendly and efficient,
 which helps to reduce the costs and  delays of carrying out the studies
+Reduces training time to the specific time for learning the software solution
 which has been based on this platform
+All functionalities are accessible through the programmatic
 integrated Python console

This package contains YACS module.

WWW: http://www.salome-platform.org
- Stas Timokhin
devel@stasyan.com

PR:		ports/143469
Submitted by:	Stas Timokhin <devel at stasyan.com>
2010-02-12 22:17:05 +00:00

20 lines
1.3 KiB
Text

--- src/engine/Makefile.am.orig 2009-12-01 20:58:28.000000000 +0600
+++ src/engine/Makefile.am 2010-01-06 15:56:36.000000000 +0600
@@ -88,7 +88,7 @@
Dispatcher.hxx DynParaLoop.hxx ElementaryNode.hxx Executor.hxx \
ForEachLoop.hxx ForLoop.hxx InGate.hxx InlineNode.hxx InPort.hxx \
InputDataStreamPort.hxx InputPort.hxx InvalidExtractionException.hxx LinkInfo.hxx Logger.hxx \
-LogRecord.hxx Loop.hxx Node.hxx OptimizerAlg.hxx OptimizerLoop.hxx \
+LogRecord.hxx Loop.hxx OptimizerAlg.hxx OptimizerLoop.hxx \
OutGate.hxx OutPort.hxx OutputDataStreamPort.hxx OutputPort.hxx Pool.hxx \
Port.hxx Proc.hxx RefCounter.hxx Runtime.hxx Scheduler.hxx \
ServiceInlineNode.hxx ServiceNode.hxx SharedPtr.hxx StaticDefinedComposedNode.hxx Switch.hxx \
@@ -101,7 +101,7 @@
$(__dummy__)
libYACSlibEngine_la_LIBADD = ../bases/libYACSBases.la
-libYACSlibEngine_la_LDFLAGS = -pthread -lpthread -ldl
+libYACSlibEngine_la_LDFLAGS = -pthread
AM_CXXFLAGS = $(THREAD_DEF) \
-I$(srcdir)/../bases