freebsd-ports/audio/kmix-kde4/files/extrapatch-no_alsa
Tobias C. Berner a4a7daf069 Give the KDE SC4 applications ports a -kde4 suffix
In order to make room for the up-to-date version of the KDE Desktop and its
applications move the KDE Application ports based on Qt4.

PR:		225992
Exp-run by:	antoine
Reviewed by:	rakuco, adridg
Differential Revision:	https://reviews.freebsd.org/D14413
2018-02-22 19:03:17 +00:00

20 lines
914 B
Text

--- CMakeLists.txt.orig 2014-07-16 08:24:17 UTC
+++ CMakeLists.txt
@@ -9,7 +9,7 @@ include(MacroLibrary)
# Do not yet REQUIRE Phonon. Hint: As long as we do not find_package(), ${KDE4_PHONON_LIBS} will be empty below, but that should not hurt.
#find_package(Phonon REQUIRED)
-find_package(Alsa)
+find_file(CONFIG_ALSA_H_CMAKE config-alsa.h.cmake ${CMAKE_MODULE_PATH})
set(PA_VER "0.9.16")
macro_optional_find_package(PulseAudio "${PA_VER}")
@@ -20,7 +20,7 @@ macro_optional_find_package(Canberra)
macro_log_feature(CANBERRA_FOUND "libcanberra" "libcanberra audio library"
"http://0pointer.de/lennart/projects/libcanberra/" FALSE "" "libcanberra is needed for kmix sound feedback")
-alsa_configure_file(${CMAKE_BINARY_DIR}/config-alsa.h)
+configure_file(${CONFIG_ALSA_H_CMAKE} ${CMAKE_BINARY_DIR}/config-alsa.h)
add_definitions (${QT_DEFINITIONS} ${QT_QTDBUS_DEFINITIONS} ${KDE4_DEFINITIONS} )