freebsd-ports/comms/smstools3/files/patch-scripts_sendsms
Guido Falsi ad3225e349 - Add UTF8 option [1]
- Patch sendsms script to correctly parse iconv command output [2]

While here:

- Add TIMESTAMP to distinfo
- Regenerate patches
- Unsilence post-install target

PR:		205973 [1], 205978 [2]
Submitted by:	satorium77@gmail.com
2016-11-02 11:29:28 +00:00

11 lines
356 B
Text

--- scripts/sendsms.orig 2010-07-08 12:41:13 UTC
+++ scripts/sendsms
@@ -80,7 +80,7 @@ echo "Text: $TEXT"
ALPHABET=""
if which iconv > /dev/null 2>&1; then
- if ! $ECHO -n "$TEXT" | iconv -t ISO-8859-15 >/dev/null 2>&1; then
+ if $ECHO -n "$TEXT" | iconv -t ISO-8859-15 2>&1 | grep "invalid" > /dev/null; then
ALPHABET="Alphabet: UCS"
fi
fi