36353c589f
- Add Makefile.common o A new build/install system for gecko ports, Makefile.common includes many generic routines and common tasks. o Fix ld-run-path in all gecko's by using -Wl,-rpath,${moz_libdir} thus removing the need to have a startup script for ports that depend on gecko. [2] o Use system libm, nss, nspr in all gecko ports - Add bsd.gecko.mk o This is the predecessor to WITH_MOZILLA=[mozilla|firefox|...] with a more robust way of detecting a gecko a end user wishs to use. o bsd.gecko.mk abstracts the selection of gecko-based backends. It allows users and porters to support any available gecko backend without needing to build many conditional tests. ${USE_GECKO} is the list of backends that your port can handle, and ${GECKO} is set by bsd.gecko.mk to be the chosen backend. Users set ${WITH_GECKO} to the list of gecko backends they want on their system. Port Makefile example: USE_GECKO=firefox mozilla seamonkey thunderbird .include <bsd.port.pre.mk> .include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk" End user example: WITH_GECKO=seamonkey firefox We highly recommend moving away from using WITH_MOZILLA and switching to USE/WITH_GECKO. PR: 89052 [2] Submitted by: vs [2] Obtained from: www/firefox Thanks to: adamw, marcus, and mezz for ideas, bug squashing, and more sajd from irc.freenode.org/#FreeBSD-Gnome for pointing out many bugs
65 lines
2.5 KiB
Text
65 lines
2.5 KiB
Text
--- configure.orig Tue Oct 12 00:13:29 2004
|
|
+++ configure Wed Nov 23 01:48:55 2005
|
|
@@ -9368,7 +9368,7 @@
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
ac_save_LIBS="$LIBS"
|
|
-LIBS="-liconv $LIBS"
|
|
+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
|
|
cat > conftest.$ac_ext <<EOF
|
|
#line 9374 "configure"
|
|
#include "confdefs.h"
|
|
@@ -9399,7 +9399,7 @@
|
|
fi
|
|
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
|
echo "$ac_t""yes" 1>&6
|
|
- _ICONV_LIBS="$_ICONV_LIBS -liconv"
|
|
+ _ICONV_LIBS="$_ICONV_LIBS -L$LOCALBASE/lib -liconv"
|
|
else
|
|
echo "$ac_t""no" 1>&6
|
|
echo $ac_n "checking for libiconv in -liconv""... $ac_c" 1>&6
|
|
@@ -9409,7 +9409,7 @@
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
ac_save_LIBS="$LIBS"
|
|
-LIBS="-liconv $LIBS"
|
|
+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
|
|
cat > conftest.$ac_ext <<EOF
|
|
#line 9415 "configure"
|
|
#include "confdefs.h"
|
|
@@ -9440,7 +9440,7 @@
|
|
fi
|
|
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
|
echo "$ac_t""yes" 1>&6
|
|
- _ICONV_LIBS="$_ICONV_LIBS -liconv"
|
|
+ _ICONV_LIBS="$_ICONV_LIBS -L$LOCALBASE/lib -liconv"
|
|
else
|
|
echo "$ac_t""no" 1>&6
|
|
fi
|
|
@@ -11401,12 +11401,12 @@
|
|
|
|
echo $ac_n "checking MOZ_GTK2_CFLAGS""... $ac_c" 1>&6
|
|
echo "configure:11404: checking MOZ_GTK2_CFLAGS" >&5
|
|
- MOZ_GTK2_CFLAGS=`$PKG_CONFIG --cflags "gtk+-2.0 >= 1.3.7"`
|
|
+ MOZ_GTK2_CFLAGS=`$PKG_CONFIG --cflags "gtk+-2.0 >= 1.3.7" "pangox >= 1.1.0"`
|
|
echo "$ac_t""$MOZ_GTK2_CFLAGS" 1>&6
|
|
|
|
echo $ac_n "checking MOZ_GTK2_LIBS""... $ac_c" 1>&6
|
|
echo "configure:11409: checking MOZ_GTK2_LIBS" >&5
|
|
- MOZ_GTK2_LIBS=`$PKG_CONFIG --libs "gtk+-2.0 >= 1.3.7"`
|
|
+ MOZ_GTK2_LIBS=`$PKG_CONFIG --libs "gtk+-2.0 >= 1.3.7" "pangox >= 1.1.0"`
|
|
echo "$ac_t""$MOZ_GTK2_LIBS" 1>&6
|
|
else
|
|
MOZ_GTK2_CFLAGS=""
|
|
@@ -12344,9 +12344,9 @@
|
|
|
|
|
|
|
|
-MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector irc universalchardet typeaheadfind webservices spellcheck gnomevfs negotiateauth"
|
|
+MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector universalchardet typeaheadfind webservices spellcheck gnomevfs negotiateauth"
|
|
|
|
-MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT xmlterm datetime finger cview layout-debug tasks"
|
|
+MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT irc xmlterm datetime finger cview layout-debug tasks"
|
|
|
|
# Check whether --enable-extensions or --disable-extensions was given.
|
|
if test "${enable_extensions+set}" = set; then
|