freebsd-ports/net-mgmt/noc/files/patch-scripts_post-install
Beech Rintoul 6eab245ddd -Update to 0.6.4
-Changes in port:
-Change depends of django to django-1.3.x version only
-Add options for make 'noc' with GMPY and PEP8 modules
-Remove creating user anf group from pkg-install script and use bsd.port.mk
 mechanism.
-Autogenerate PLIST file from MANIFEST file in distribution.

PR:		ports/156809
Submitted by:	Stanislav A Svirid <count@211.ru> (maintainer)
Approved by:	itetcu (mentor)(implicit)
2011-05-11 17:15:54 +00:00

33 lines
1,016 B
Text

--- scripts/post-install.orig 2009-07-29 18:22:59.000000000 +0700
+++ scripts/post-install 2009-07-29 18:25:16.000000000 +0700
@@ -5,7 +5,7 @@
## Copyright (C) 2007-2009 The NOC Project
## See LICENSE for details
##----------------------------------------------------------------------
-PREFIX=/opt/noc
+PREFIX=/usr/local/noc
cd $PREFIX
@@ -15,7 +15,7 @@ cd $PREFIX
sed_script=`mktemp tmp.XXXXXX`
rm $sed_script
for cmd in ssh rsync pg_dump tar gzip smidump smilint fping dig gpg; do
- echo 's@^\\($cmd *\\)=.*\$@\\1 = '`which $cmd`'@' >> $sed_script
+ echo "s@^\\($cmd *\\)=.*\$@\\1 = "`which $cmd`'@' >> $sed_script
done
##
@@ -30,10 +30,11 @@ done
rm $sed_script
chmod 640 etc/*.conf
chown noc:noc etc/*.conf
+chmod -R +r share/mibs/
##
## Create required directories
##
-for d in local static/doc /var/repo /var/backup /var/log/noc; do
+for d in local static/doc /var/db/noc /var/db/noc/repo /var/db/noc/backup /var/log/noc; do
[ ! -d $d ] && mkdir $d
chown noc:noc $d
done