903b45dfc5
merely pick up and help him. Thanks to many testers in both private and mailing list emails for report a few of build and dependencies problems. Also, thanks to marcus and Chess Griffin for test in their tinderboxes. x11/pixman: Update to 0.10.0 ------------------------------------------------------- Firefox 3 needs it. Orignal, the shared library was bumped and ahze has added a new feature in our USE_GNOME=ltverhack by can control the number of shared library. To control the number of shared library, add the ltverhack:N. Right now pixman has USE_GNOME=ltverhack:9 to make it stays same at libpixman-1.so.9. If anyone want to use ltverhack:N in one of your port, you need to make sure the ABI doesn't change to use it.. ------------------------------------------------------- graphics/cairo: Update to 1.6.4 ------------------------------------------------------- Firefox 3 needs it. We have updated most cairo binding ports too. ------------------------------------------------------- graphics/poppler: Update to 0.8.3 ------------------------------------------------------- The shared libraries version have been changed. All ports that depend on poppler have PORTREVISION bump. The graphics/py-poppler has been updated to 0.8.1 to work with newer poppler better. As for the poppler-qt, there is no shared library version change. ------------------------------------------------------- www/firefox3 and gecko ports related: Update to 3.0 final ------------------------------------------------------- The bsd.gecko.mk has been moved from www/mozilla/ to Mk/. You no longer need to include bsd.gecko.mk/Makefile.common by manual. We are keeping it in backward compatibility, so the rest ports won't be break. We haven't add some other ports to have Firefox 3 support yet, so feel free to send us patch or commit it by yourself (to committers). However, view in bsd.gecko.mk for document. ------------------------------------------------------- Approved by: portmgr (marcus)
39 lines
1.4 KiB
Text
39 lines
1.4 KiB
Text
--- qt/Makefile.in.orig 2008-03-27 08:17:35.000000000 -0400
|
|
+++ qt/Makefile.in 2008-03-27 08:18:20.000000000 -0400
|
|
@@ -59,8 +59,7 @@
|
|
libLTLIBRARIES_INSTALL = $(INSTALL)
|
|
LTLIBRARIES = $(lib_LTLIBRARIES)
|
|
am__DEPENDENCIES_1 =
|
|
-libpoppler_qt_la_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
|
|
- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
|
|
+libpoppler_qt_la_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
|
|
$(am__DEPENDENCIES_1)
|
|
am_libpoppler_qt_la_OBJECTS = poppler-document.lo poppler-fontinfo.lo \
|
|
poppler-link.lo poppler-page.lo poppler-page-transition.lo
|
|
@@ -71,7 +70,7 @@
|
|
PROGRAMS = $(noinst_PROGRAMS)
|
|
am_test_poppler_qt_OBJECTS = test-poppler-qt.$(OBJEXT)
|
|
test_poppler_qt_OBJECTS = $(am_test_poppler_qt_OBJECTS)
|
|
-test_poppler_qt_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
|
|
+test_poppler_qt_DEPENDENCIES = \
|
|
libpoppler-qt.la $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
|
|
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir) -I$(top_builddir)/poppler
|
|
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
|
@@ -273,7 +272,7 @@
|
|
poppler-private.h
|
|
|
|
libpoppler_qt_la_LIBADD = \
|
|
- $(top_builddir)/poppler/libpoppler.la \
|
|
+ -lpoppler -lqt-mt \
|
|
$(POPPLER_QT_LIBS) \
|
|
$(FREETYPE_LIBS) \
|
|
$(FONTCONFIG_LIBS)
|
|
@@ -283,7 +282,7 @@
|
|
test-poppler-qt.cpp
|
|
|
|
test_poppler_qt_LDADD = \
|
|
- $(top_builddir)/poppler/libpoppler.la \
|
|
+ -lpoppler -lqt-mt \
|
|
libpoppler-qt.la \
|
|
$(POPPLER_QT_LIBS) \
|
|
$(FREETYPE_LIBS)
|